summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-10 06:18:24 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-10 07:12:55 +0200
commitb8610df8289d55de5fd150cdb0c676f30f3608e0 (patch)
tree5e11e4d4a134ec2df3d20055a007795e40baef97 /dev-python/botocore
parentdev-ruby/rack-session: Stabilize 2.0.0 ppc, #935799 (diff)
downloadgentoo-b8610df8289d55de5fd150cdb0c676f30f3608e0.tar.gz
gentoo-b8610df8289d55de5fd150cdb0c676f30f3608e0.tar.bz2
gentoo-b8610df8289d55de5fd150cdb0c676f30f3608e0.zip
dev-python/botocore: Bump to 1.34.142
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.142.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 4f27f2e35dd1..8d37e1575318 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -2,3 +2,4 @@ DIST botocore-1.34.131.gh.tar.gz 13129943 BLAKE2B 916360c6a9526edcfd338718f80556
DIST botocore-1.34.136.gh.tar.gz 13151618 BLAKE2B 800b800ff2481335f0defb79c10a4216c8bb107a3369e6a45a9c0a6d8f703209a9e44560ebf859f7fc616498c68e9b0de331478a8b5e2d3b36788bdedb597a0b SHA512 e9a31f6e8e241964fa34df65c8a9f8acaa1e33865eeb8257bf6da16982a3704b8ab66b6f424952ff100944471bb8f40cbdbcc26f72120da2d6033319948de81e
DIST botocore-1.34.140.gh.tar.gz 13156596 BLAKE2B 4a264fe767c35dcc65ddbe1eb29529d2576553e4d6f9a3d6c28f249aaa0eab5a0fd150fdbdc1dbd1b83cc1fb6fce8f58c68de43f5dc338cb3feb5b9f76c8f973 SHA512 36c90da9670639ccc10e65ced501a2b16e50b664f11be2686f6fcfc56fa81271f160b27b7ffac513446afe09ef6ed4768818ad8b8ca540571737c47fdf980443
DIST botocore-1.34.141.gh.tar.gz 13177346 BLAKE2B f62ffb736687cb016d0aa3c00b74c8ffbddadc0f7e47bfed9087872f930fcb85a03da9c3f9c494f21a405afc7c0d5f8e9d50d7c3cefa9c1ea17a97d5f184feff SHA512 91b0f6007e7f030f9ab0c83276884ea993cdaa1f395c51ff4ff3a43e4a8b6f80eed4a93f4f5248984f00b51a44cfe37d51cce70147ed5a578cc0e006c2d0b4dd
+DIST botocore-1.34.142.gh.tar.gz 13181218 BLAKE2B a8bb49e11e0b6a308462501fa578939089792ba1a838e601ff76b6271eec16f32bbb6d489dee474008108198e0ac48fb25438f79428fc4cba9d575f56bee8d52 SHA512 66ebf68e478a4c2b5be44f5784ef5b117d729ca53eb5754eb0eb2540555aad6f3e95e4007bdbe76173d43c35cb79f30c800fa152ce69977399d5821761fcca28
diff --git a/dev-python/botocore/botocore-1.34.142.ebuild b/dev-python/botocore/botocore-1.34.142.ebuild
new file mode 100644
index 000000000000..a485364722b9
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.142.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # memory use tests, probably fragile
+ tests/functional/leak/test_resource_leaks.py::TestDoesNotLeakMemory::test_create_single_paginator_memory_constant
+ tests/functional/leak/test_resource_leaks.py::TestDoesNotLeakMemory::test_create_single_waiter_memory_constant
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}