summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-14 02:48:56 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-14 02:48:56 +0200
commit876bc034d5a0dce6569ba43a031d6d3039bf29d0 (patch)
tree48c26c4075b925757234ba18d6966466e5188747 /dev-python/botocore
parentdev-perl/CGI: Stabilize 4.640.0 sparc, #933954 (diff)
downloadgentoo-876bc034d5a0dce6569ba43a031d6d3039bf29d0.tar.gz
gentoo-876bc034d5a0dce6569ba43a031d6d3039bf29d0.tar.bz2
gentoo-876bc034d5a0dce6569ba43a031d6d3039bf29d0.zip
dev-python/botocore: Bump to 1.34.126
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.126.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index e4a0c4e8ffc2..cf1f62e47008 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,3 +4,4 @@ DIST botocore-1.34.122.gh.tar.gz 13066937 BLAKE2B f22af79873b5574ae4b2b9041568cf
DIST botocore-1.34.123.gh.tar.gz 13080868 BLAKE2B a15ecc1151803d26181c72117df62a6777c2d209cc1a49eb106d7a779fab23300762d8e034e9dc79c8eb747d6e31b5ea75739698809797bea9fe3c930b72b40a SHA512 20f77200edd899b957c7544ba7faed4fb7fd6a0fb6c0fe95cd729c67b3f47bb2414ed413c145fcc9e0f1e55f2cee86398580b9b71d38b70043d01efbe48e9510
DIST botocore-1.34.124.gh.tar.gz 13097299 BLAKE2B 1dd7353ca2ae93199995530057cdd90dbaf1a4e493ca7be1e7b4cc445dfa0d352f02b903a6264dd67105f2826df05ed01aa1a861545ab28369519183b731365a SHA512 5e53a80571811faa306926aa7f72d802f720040c6a613aacadcb00e331259185ccfed91bd1fdffefddc069ae58cd80454b182d4965273bc10921cb2625ebf793
DIST botocore-1.34.125.gh.tar.gz 13105188 BLAKE2B 2db46c6a07c7e75a57872416c7302d250661e24c0f81f65138d12f19fab934c480eea809bb748fd00c9d64b3d97191896477ee2b0bdf96421d7bd82e872e7f7e SHA512 413f986d3d9da2bc9c08f4f2358fb1c47020c02533b3a550f0efd3fe974269d9178c16f5387c41efd23802e9bec795b3f77ab0aae7cac8d5515981eb404861a2
+DIST botocore-1.34.126.gh.tar.gz 13107136 BLAKE2B d26cc2cd8c460d64dbe41cc14a22a115c8c75f2cb5f23ba34df740fcada62e991e3751f4eddc34c1517939274ae6175d00d78ac199d3329027842ac24c985138 SHA512 9b7c010df304e36e767492ae7a31749d9e8ffa8fd1161478f515983c345d13576ffcd941e166412aa53f3dd36b409e3b38bf900d4f007e607f56236ee3ce0eef
diff --git a/dev-python/botocore/botocore-1.34.126.ebuild b/dev-python/botocore/botocore-1.34.126.ebuild
new file mode 100644
index 000000000000..ba6cd2a5d2a2
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.126.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}