summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-06 20:56:41 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-06 21:35:46 +0200
commit7b3ea9b39f8d0907b929213d506290f97921095b (patch)
treef467941e8ac4a060f600ff822e8657160066cdcc /dev-python/botocore
parentdev-python/bashate: enable py3.13 (diff)
downloadgentoo-7b3ea9b39f8d0907b929213d506290f97921095b.tar.gz
gentoo-7b3ea9b39f8d0907b929213d506290f97921095b.tar.bz2
gentoo-7b3ea9b39f8d0907b929213d506290f97921095b.zip
dev-python/botocore: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/botocore-1.34.140.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-python/botocore/botocore-1.34.140.ebuild b/dev-python/botocore/botocore-1.34.140.ebuild
index ba6cd2a5d2a2..a485364722b9 100644
--- a/dev-python/botocore/botocore-1.34.140.ebuild
+++ b/dev-python/botocore/botocore-1.34.140.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
@@ -62,6 +62,16 @@ python_test() {
tests/functional/test_six_threading.py::test_six_thread_safety
)
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # memory use tests, probably fragile
+ tests/functional/leak/test_resource_leaks.py::TestDoesNotLeakMemory::test_create_single_paginator_memory_constant
+ tests/functional/leak/test_resource_leaks.py::TestDoesNotLeakMemory::test_create_single_waiter_memory_constant
+ )
+ ;;
+ esac
+
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest tests/{functional,unit}
}