summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-18 05:22:49 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-18 05:22:49 +0200
commit7b0b418e5f5a0db6274ab6fc6ed9f5fd71716f9b (patch)
treefdcf0b368af8a7031b9ead1b952d0cd48aeed687 /dev-python/botocore
parentdev-cpp/gtest: fix test failure on x86 (diff)
downloadgentoo-7b0b418e5f5a0db6274ab6fc6ed9f5fd71716f9b.tar.gz
gentoo-7b0b418e5f5a0db6274ab6fc6ed9f5fd71716f9b.tar.bz2
gentoo-7b0b418e5f5a0db6274ab6fc6ed9f5fd71716f9b.zip
dev-python/botocore: Bump to 1.34.128
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.128.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 7a0135f2bf86..92c0b0c14913 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
DIST botocore-1.34.117.gh.tar.gz 13076178 BLAKE2B defbd66d6409004fe49df44aec0a00b4bbe1a459d3e4b067c5c8609b998c63e7d62c8d3c48805416d44c08aeb3ab261f4449cc7e6a7c66dd3ca5f97bdcce291f SHA512 d9736ddb868e602afbaad95989d284b2835636f273e8a4263caa7eec619fe7cc45515fbbe98d4fd33121fe0d97d34353f7cd811bc878a81d1f5f7437798b24d6
DIST botocore-1.34.122.gh.tar.gz 13066937 BLAKE2B f22af79873b5574ae4b2b9041568cfc1d727625c3fa45c9b8d1bef71ffcce893aa8a3591c83160437c7e617be72814a2209569db633d857f869a2152af7c8e05 SHA512 f08dcb2920d4bd26a47478edb871f75b240275a7b96acf58be838080dddca3d4f64b9fda8683e5a3db97defe367298b2ba634fc4d605523805b23c83c3a5ae0d
DIST botocore-1.34.127.gh.tar.gz 13112261 BLAKE2B e883f0a1e29178667678132195aea9666a124456e731e1b158eed895c125fd614e5671639766f7ad46c2e6b16c4156ff5e42594bc04e49bf25380c91cfcbe264 SHA512 48ca2179c24bb219202e5029dd62350a6fc5c64707762f0f33282e542dbc2227bb146376afa9e6b9eb1e45e3c801208a142bef4827d5036eb4724299c826d534
+DIST botocore-1.34.128.gh.tar.gz 13115625 BLAKE2B 77be2cb79722d1052b64df55a7bb7a9d43dc7d0052c2a4ce18265745edb7b6f9f30780a98f2395abadcfc16817e7375b182691b51f44450574846cc4bb423df5 SHA512 d5f709230ba73ea7c78a4b55a07c0d834b1abf2c3196d43d47d042e1cb190f5d8d08ad942053963ad5df9b2e01b5f905d167840f54842a41181de5305762d5d1
diff --git a/dev-python/botocore/botocore-1.34.128.ebuild b/dev-python/botocore/botocore-1.34.128.ebuild
new file mode 100644
index 000000000000..ba6cd2a5d2a2
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.128.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}