summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-04 06:40:13 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-04 07:19:17 +0200
commit1c957614a96fe2de6f8b0f48cdab5e931a94fbe0 (patch)
treec66eed903debdc7fbf9a6958dc2715f70f9f742a /dev-python/botocore
parentdev-ruby/json: allow all ragel versions (diff)
downloadgentoo-1c957614a96fe2de6f8b0f48cdab5e931a94fbe0.tar.gz
gentoo-1c957614a96fe2de6f8b0f48cdab5e931a94fbe0.tar.bz2
gentoo-1c957614a96fe2de6f8b0f48cdab5e931a94fbe0.zip
dev-python/botocore: Bump to 1.34.118
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.118.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 93451c12f7c7..733b401ce8ff 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
DIST botocore-1.34.108.gh.tar.gz 13029228 BLAKE2B 947c11bb991e9e7622412bb7e90579e56d688b43ed836fb95ac133520221f56c2e96dc3a6d8b939d334ee4b4ad6ce8b30259c671be1bf9b3fc3deae62391674c SHA512 af23c80879d12cbb279741c216b99bf643b09ef516837275d31f6fbce253863027741b0cd6c815ae32bb6f41ebf0d33c8f2120ec81d6a3803cd0ffeab7be91e1
DIST botocore-1.34.113.gh.tar.gz 13060395 BLAKE2B 8f9329d613f489f2305d068566940a94199a16e9d538597a86cd916a331245a70c6ad771f0d7d71a05a77a49c86aa8ff6be2ac6cd97c04828cc9f54cb6c5e2ac SHA512 218656c921b7ae6a605d6cca4cb90b76aee2a18541e78189828f2adfbb821fbebac406ba19887c0a07aece72dd4936f41b057fb25611e1b03db4bd11fda66bd6
DIST botocore-1.34.117.gh.tar.gz 13076178 BLAKE2B defbd66d6409004fe49df44aec0a00b4bbe1a459d3e4b067c5c8609b998c63e7d62c8d3c48805416d44c08aeb3ab261f4449cc7e6a7c66dd3ca5f97bdcce291f SHA512 d9736ddb868e602afbaad95989d284b2835636f273e8a4263caa7eec619fe7cc45515fbbe98d4fd33121fe0d97d34353f7cd811bc878a81d1f5f7437798b24d6
+DIST botocore-1.34.118.gh.tar.gz 13078257 BLAKE2B 3fbd875002373cd883daee9b2f5669f24ad45c8524b26d82ac732ad7387e2910783cf912c239f61b6c107a571bdf6db36f04cde0bb979d531544630b99e7de68 SHA512 04785ddfc67507bd0023f86bb7f9048c6fcb498ba3933186fc925d1554bf8c6dcf2499ef980393cd0dbd1e95dc835585d39c24ae005dbf3887477f86187e7be4
diff --git a/dev-python/botocore/botocore-1.34.118.ebuild b/dev-python/botocore/botocore-1.34.118.ebuild
new file mode 100644
index 000000000000..ba6cd2a5d2a2
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.118.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}