summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-21 02:47:21 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-21 03:46:48 +0200
commit0e08eb11451c13919ce3f6093013924f427f07b0 (patch)
tree7ad63de4ab827ccbc9dd0f2aed7eeabd2ec62909 /dev-python/botocore
parentdev-qt/qtwebengine: alternate fix for USE="pdfium -pulseaudio" (qt6) (diff)
downloadgentoo-0e08eb11451c13919ce3f6093013924f427f07b0.tar.gz
gentoo-0e08eb11451c13919ce3f6093013924f427f07b0.tar.bz2
gentoo-0e08eb11451c13919ce3f6093013924f427f07b0.zip
dev-python/botocore: Bump to 1.34.131
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.131.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 35c2f2370304..ca6b2a244dee 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,3 +4,4 @@ DIST botocore-1.34.127.gh.tar.gz 13112261 BLAKE2B e883f0a1e29178667678132195aea9
DIST botocore-1.34.128.gh.tar.gz 13115625 BLAKE2B 77be2cb79722d1052b64df55a7bb7a9d43dc7d0052c2a4ce18265745edb7b6f9f30780a98f2395abadcfc16817e7375b182691b51f44450574846cc4bb423df5 SHA512 d5f709230ba73ea7c78a4b55a07c0d834b1abf2c3196d43d47d042e1cb190f5d8d08ad942053963ad5df9b2e01b5f905d167840f54842a41181de5305762d5d1
DIST botocore-1.34.129.gh.tar.gz 13122365 BLAKE2B bbe68547fd9cab43c75368091abd81e3cf602e3df2f9ea4ab79250f12ba34ea410ce50683309001b1898a6c7c5fb3e23dda145833f4db74304417e665bcf1ce1 SHA512 bea364bf0185a6a9086fd712ccfec7fa0870328fe4569d8553ccfea8577c3b64212e7860a37aeec35fbb7bd1a179c32d487ecdc98651076b27a8f07429c843b4
DIST botocore-1.34.130.gh.tar.gz 13122638 BLAKE2B f43167295b7cd590fbca8c2910fb5e1eca159c3cc77912e901d9caf95fac9cb7d38712b68c3f8115fbfbb2346944a24f42a1e707f23c53d23a64dec9656453b0 SHA512 d6102b5a7d519de3a69aea26ac89cd38cead5c8f1c86f9c6be6c05c50ce23bd9f2ff3115505230e3de46430a7a25dda63896773cab6c31f410d845e2d3ac4abb
+DIST botocore-1.34.131.gh.tar.gz 13129943 BLAKE2B 916360c6a9526edcfd338718f80556e59d54692aac13f38490e49457edd59016d264a5acbfeb6298af494f09f9c385e16347a9bf7f144c5a11afda2df188aeed SHA512 9bb788ac8e8a2ec7be999acafef88ccbb4e693ccb315efe5655b80cf3f6629eebccbdac6f201550d2f75e476d83c5a800f1add6c71e2fe5b3d503da313f6d3d3
diff --git a/dev-python/botocore/botocore-1.34.131.ebuild b/dev-python/botocore/botocore-1.34.131.ebuild
new file mode 100644
index 000000000000..ba6cd2a5d2a2
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.131.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}