summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-27 03:40:11 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-27 04:53:32 +0200
commit0d9eca2599d8f3e627d3da7a20eee914f7ff23f3 (patch)
tree9c8de0089fd5dee5a439fe4fe3c539dccc8c0d74 /dev-python/botocore
parentgames-roguelike/stone-soup: enable py3.13 (diff)
downloadgentoo-0d9eca2599d8f3e627d3da7a20eee914f7ff23f3.tar.gz
gentoo-0d9eca2599d8f3e627d3da7a20eee914f7ff23f3.tar.bz2
gentoo-0d9eca2599d8f3e627d3da7a20eee914f7ff23f3.zip
dev-python/botocore: Bump to 1.34.134
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.134.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 7fa24e5d70e0..b5c17e876f25 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -3,3 +3,4 @@ DIST botocore-1.34.127.gh.tar.gz 13112261 BLAKE2B e883f0a1e29178667678132195aea9
DIST botocore-1.34.131.gh.tar.gz 13129943 BLAKE2B 916360c6a9526edcfd338718f80556e59d54692aac13f38490e49457edd59016d264a5acbfeb6298af494f09f9c385e16347a9bf7f144c5a11afda2df188aeed SHA512 9bb788ac8e8a2ec7be999acafef88ccbb4e693ccb315efe5655b80cf3f6629eebccbdac6f201550d2f75e476d83c5a800f1add6c71e2fe5b3d503da313f6d3d3
DIST botocore-1.34.132.gh.tar.gz 13131027 BLAKE2B 044d1ad5d843a8fa924ba71d66e025cf81ff7c0f1b6d47bb52d0b38ea9a25617218b9789449bbee782010daefa328e6d7327e7663133bc624143c71749876a00 SHA512 b029fdebeb9cce956bbe012b2145131368e93a9d255f9253ce0780d1b311061b8ce3353e1d3a083616dec299e1d8d4c829f58f1414781971c0122ee43d80c869
DIST botocore-1.34.133.gh.tar.gz 13132822 BLAKE2B 156ffc12d6f880fb3bea95c08eabad14c6b0f53e0ffa53410a20b8d96ccb2147d0ee7efadcd4d281f2551dd12567d40868f17187f0e2c0d1061835f0ff20a685 SHA512 36b0b9c9234e226090d552713c0de0a7cd5265e35225a9af156ab3443c456b03967cbd0a60ceb87c746e0a14d33eda303b9c8bc9814a28bc322d5517aa7dc00a
+DIST botocore-1.34.134.gh.tar.gz 13136754 BLAKE2B c89a5d72f5777587cd3246e33100d271a8e937f2fea516e2772e31edb1f6065502b3342aa72e4739ca8e5a581401657009b870f7259ea7b94a1af7203961af8e SHA512 2e1d3041fca06293c77d94bce8be74bc2a4625659bd37f513a8ae836472c67c0f2166cb03f77821166b2323c51b09305ef2f83aaa68f08f53f01801794837f78
diff --git a/dev-python/botocore/botocore-1.34.134.ebuild b/dev-python/botocore/botocore-1.34.134.ebuild
new file mode 100644
index 000000000000..ba6cd2a5d2a2
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.134.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}