summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-04-29 19:10:13 +0200
committerPacho Ramos <pacho@gentoo.org>2020-04-29 19:10:36 +0200
commita7f15a15a568b0dd88f7c4489f493ef99984ec8d (patch)
tree0ecd57648a6e9b4c496af54a9872c7e8e5f807fe /dev-python/booleanOperations
parentsci-geosciences/qmapshack: bump to 1.14.1 (diff)
downloadgentoo-a7f15a15a568b0dd88f7c4489f493ef99984ec8d.tar.gz
gentoo-a7f15a15a568b0dd88f7c4489f493ef99984ec8d.tar.bz2
gentoo-a7f15a15a568b0dd88f7c4489f493ef99984ec8d.zip
dev-python/booleanOperations: Newer pyclipper needed, skip tests for now
Bug: https://bugs.gentoo.org/719882 Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-python/booleanOperations')
-rw-r--r--dev-python/booleanOperations/booleanOperations-0.9.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/booleanOperations/booleanOperations-0.9.0-r1.ebuild b/dev-python/booleanOperations/booleanOperations-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..8904255b6273
--- /dev/null
+++ b/dev-python/booleanOperations/booleanOperations-0.9.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Boolean operations on paths"
+HOMEPAGE="https://github.com/typemytype/booleanOperations"
+SRC_URI="https://github.com/typemytype/booleanOperations/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+BDEPEND=""
+RDEPEND="${DEPEND}
+ >=dev-python/fonttools-4.0.2[${PYTHON_USEDEP}]
+ >=dev-python/pyclipper-1.1.0_p3[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests setup.py
+
+# tests need fontPens, that is not packaged
+RESTRICT="test"
+
+src_prepare() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
+ distutils-r1_src_prepare
+}