summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-04-07 19:55:04 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-04-07 19:55:04 +0300
commitf51728bf4e726bfc8d793df1e2ec3a83c4bd9031 (patch)
treec855ebe4f098629b3759eaef85df327e986a2aad /dev-python/bleach
parentdev-python/voluptuous: add 0.13.1 (diff)
downloadgentoo-f51728bf4e726bfc8d793df1e2ec3a83c4bd9031.tar.gz
gentoo-f51728bf4e726bfc8d793df1e2ec3a83c4bd9031.tar.bz2
gentoo-f51728bf4e726bfc8d793df1e2ec3a83c4bd9031.zip
dev-python/bleach: add 5.0.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/bleach')
-rw-r--r--dev-python/bleach/Manifest1
-rw-r--r--dev-python/bleach/bleach-5.0.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/bleach/Manifest b/dev-python/bleach/Manifest
index a597f703e6a0..0076f2a300c8 100644
--- a/dev-python/bleach/Manifest
+++ b/dev-python/bleach/Manifest
@@ -1 +1,2 @@
DIST bleach-4.1.0.tar.gz 195798 BLAKE2B 68afd58aa099acb5c21f1ff76301c46834f326ea2aa4fe7a6f820c2cf31913e81dc72deecab4272b2a7ceab1ae01bec028a5cf5e6214cddef4cdec5ec05ea4c6 SHA512 34c522dde5126995789e23fd28f7938d025f56e97e30814dc326d33a772d40fc2ad2f25aed0b367fd4352b1e1e8f54b80282b931819203bf60448ffe2f120622
+DIST bleach-5.0.0.tar.gz 198789 BLAKE2B 0b2847e9342be1854a08679230b3ea0fcb1a514eaa6c11f344057e59310b6d769e2bee91272295a0f60fa0ed1c2e4503340276d99794d260b6a63e2c4ea76703 SHA512 5b8e0c94a7bd8270581719928ec869c5c3c91900be0a293adfb342acfc55df7e63211e95786e6a39b3661b3852e91a8b37ff805387fb3e6a286e8a5dce8e3655
diff --git a/dev-python/bleach/bleach-5.0.0.ebuild b/dev-python/bleach/bleach-5.0.0.ebuild
new file mode 100644
index 000000000000..7244e10162b9
--- /dev/null
+++ b/dev-python/bleach/bleach-5.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="An easy whitelist-based HTML-sanitizing tool"
+HOMEPAGE="
+ https://github.com/mozilla/bleach/
+ https://pypi.org/project/bleach/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.0.1-r1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.1.0-py39.patch
+)
+
+src_prepare() {
+ # unbundle unpatched broken html5lib
+ rm -r bleach/_vendor || die
+ sed -i -e 's:bleach\._vendor\.::' \
+ bleach/html5lib_shim.py \
+ bleach/sanitizer.py \
+ tests/test_clean.py || die
+ # indirect html5lib deps
+ sed -i -e '/six/d' -e '/webencodings/d' setup.py || die
+
+ sed -i -e '/import/s/parse/urllib.&/' bleach/sanitizer.py || die
+
+ distutils-r1_src_prepare
+}