summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-26 14:43:18 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-26 14:43:18 +0100
commitd335f451065fd25abbe517e4c98a3534edd6ed22 (patch)
tree39179871cce44e6e9cb2a75d317291682bcb5882 /dev-python/billiard/billiard-3.5.0.2.ebuild
parentdev-python/bibtexparser: Remove redundant versions (diff)
downloadgentoo-d335f451065fd25abbe517e4c98a3534edd6ed22.tar.gz
gentoo-d335f451065fd25abbe517e4c98a3534edd6ed22.tar.bz2
gentoo-d335f451065fd25abbe517e4c98a3534edd6ed22.zip
dev-python/billiard: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/billiard/billiard-3.5.0.2.ebuild')
-rw-r--r--dev-python/billiard/billiard-3.5.0.2.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/billiard/billiard-3.5.0.2.ebuild b/dev-python/billiard/billiard-3.5.0.2.ebuild
deleted file mode 100644
index dd6ede09bfc9..000000000000
--- a/dev-python/billiard/billiard-3.5.0.2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 pypy3 )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Python multiprocessing fork"
-HOMEPAGE="https://pypi.org/project/billiard/ https://github.com/celery/billiard"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- >=dev-python/case-1.3.1[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.0[${PYTHON_USEDEP}]
- )"
-# The usual req'd for tests
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile() {
- if ! python_is_python3; then
- local CFLAGS=${CFLAGS}
- append-cflags -fno-strict-aliasing
- fi
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- use doc && esetup.py build_sphinx --builder="html" --source-dir=Doc/
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( build/sphinx/html/. )
- distutils-r1_python_install_all
-}