summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-26 08:11:47 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-26 08:43:49 +0200
commit62ad842a5de8d791b19d7886d27ccc8cbf5ca852 (patch)
tree1f77a886c5b57881113e9198c117d4433df897a4 /dev-python/async_generator
parentdev-python/ruamel-yaml-clib: Remove old (diff)
downloadgentoo-62ad842a5de8d791b19d7886d27ccc8cbf5ca852.tar.gz
gentoo-62ad842a5de8d791b19d7886d27ccc8cbf5ca852.tar.bz2
gentoo-62ad842a5de8d791b19d7886d27ccc8cbf5ca852.zip
dev-python/async_generator: Disable plugin autoload to fix tests
Closes: https://bugs.gentoo.org/840640 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/async_generator')
-rw-r--r--dev-python/async_generator/async_generator-1.10-r1.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-python/async_generator/async_generator-1.10-r1.ebuild b/dev-python/async_generator/async_generator-1.10-r1.ebuild
index 15e541a84752..3f5d16f121ee 100644
--- a/dev-python/async_generator/async_generator-1.10-r1.ebuild
+++ b/dev-python/async_generator/async_generator-1.10-r1.ebuild
@@ -18,3 +18,8 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~x6
DOCS=( README.rst )
distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}