summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-30 07:35:12 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-30 07:35:12 +0100
commit2bdf9ad1a685f4e5e87a6451894f4e05e59ab724 (patch)
tree4bce46fa94a3fae4281034c527c0362c627c5937 /dev-python/asttokens
parentdev-python/setuptools: Revert "allow disabling validation ..." (diff)
downloadgentoo-2bdf9ad1a685f4e5e87a6451894f4e05e59ab724.tar.gz
gentoo-2bdf9ad1a685f4e5e87a6451894f4e05e59ab724.tar.bz2
gentoo-2bdf9ad1a685f4e5e87a6451894f4e05e59ab724.zip
dev-python/asttokens: Bump to 3.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/asttokens')
-rw-r--r--dev-python/asttokens/Manifest1
-rw-r--r--dev-python/asttokens/asttokens-3.0.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/asttokens/Manifest b/dev-python/asttokens/Manifest
index 006d111b9da9..2017432de27f 100644
--- a/dev-python/asttokens/Manifest
+++ b/dev-python/asttokens/Manifest
@@ -1 +1,2 @@
DIST asttokens-2.4.1.gh.tar.gz 57358 BLAKE2B dff2bdbbb62ed0c99f620284e4ad4abe418c315356caee26988ed7722a9aec77be4fe79b877e350cf632e076cd7c421f6ec824e7ffdda1d6684b03fffb15e7b2 SHA512 62263e50e14953e98236cdcbd75121ff5f6a3dc949170412a97f17af9b2572415373971d2286c4821b03249404b5a4c53ef5c7f1ec37aa9e2bf4a743d16de1da
+DIST asttokens-3.0.0.gh.tar.gz 56937 BLAKE2B 38b3c9271ba57c032f552cb6dedd2cd2ef2eb6294b2f5e2fde4821260b73453495576b6641fa9450bd86f08ed4a296e010a5ce5f0f3502cbeb27857e1792802f SHA512 9d0f78ee90758d52fd15ee2f1940ddc14e8fc0d15e83fb01e731c6b79e328510f6c588c7856935aed99017b98f1daa99ee25802964990d59f63c62a0a5646804
diff --git a/dev-python/asttokens/asttokens-3.0.0.ebuild b/dev-python/asttokens/asttokens-3.0.0.ebuild
new file mode 100644
index 000000000000..1492cae51314
--- /dev/null
+++ b/dev-python/asttokens/asttokens-3.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Annotate Python AST trees with source text and token information"
+HOMEPAGE="
+ https://github.com/gristlabs/asttokens/
+ https://pypi.org/project/asttokens/
+"
+SRC_URI="
+ https://github.com/gristlabs/asttokens/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/astroid[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}