summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-05 06:25:51 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-05 06:25:51 +0100
commit8a17c23b0a92774061fedf077b27787fef875d03 (patch)
tree6077c8a270e2ca2b9ce57cab568393b986494d0b /dev-python/argh
parentdev-python/jaraco-functools: Bump to 4.0.0 (diff)
downloadgentoo-8a17c23b0a92774061fedf077b27787fef875d03.tar.gz
gentoo-8a17c23b0a92774061fedf077b27787fef875d03.tar.bz2
gentoo-8a17c23b0a92774061fedf077b27787fef875d03.zip
dev-python/argh: Bump to 0.30.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/argh')
-rw-r--r--dev-python/argh/Manifest1
-rw-r--r--dev-python/argh/argh-0.30.4.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/argh/Manifest b/dev-python/argh/Manifest
index 5dc991b43fd6..a8aa4fba23d3 100644
--- a/dev-python/argh/Manifest
+++ b/dev-python/argh/Manifest
@@ -3,3 +3,4 @@ DIST argh-0.30.0.tar.gz 59803 BLAKE2B 2e0a5d9dfbe5177ac434224b78b0575f4b2b4373ab
DIST argh-0.30.1.tar.gz 60275 BLAKE2B 24e80f51f2c2f76d605b4282045ffe98f274f3e4692a3dfc26e35aa32a97a79fdc78b795622a2cb593ed83657c1cb1ecef562b43f5b8dc3097f4909403aa98ce SHA512 a24bdc92180ebce217433842e223e958ef222dc81feba8ee22ba0b219b5c259f3d2e79f8ebdf7334b624f69c83814322aa1e768cc72f644c0b16fb2863910035
DIST argh-0.30.2.tar.gz 61528 BLAKE2B f4ef544c67cecaeaba63ca7c97425be0924712c380081971cbe67fbcfeb4a723b5a3e9bca4c33db02fb6466a4a632d756282f8e49a2c69dad4589004c3f83acc SHA512 68950e521fb6c98dbef8c1df334c2a0ae8253f6874a64d8b891c94608ac959344bae0ba65d61379796f304197f5b7f55ab8444957d1b230aa2e4d19bb080953e
DIST argh-0.30.3.tar.gz 61908 BLAKE2B 5a35d34df18c9f9bc59ca0966b034a3dfb9e337e61023c84bfb06ee4f7bc568f4c66408baf009ed4a84670bc4d13cd147cfd30ad917901fa711f7f88ee83c391 SHA512 1b3b1b9fc72794f3aa92f76fba8c24e38e1a93979a203b2d0f724d57ad6af32e3bc015ca017fd97a92e2eda9c96d5687de174133f5f7e9f2e0a736a2d9d87584
+DIST argh-0.30.4.tar.gz 62618 BLAKE2B e95ee9219d2b8079e4b9548f68811832ed9ca699c1dcfeabcf31a9a0c3fd35c107896f088a64efe430347fefd1424345753bc4e0341155a92d99a5327f4a137d SHA512 6a17fcaef3a1a400426cc53339e07583734b0b68ce9202a7b3655f5cababa495aa5269f66cde2d0b2217874ddb730bf7d1c7636dd915e4e778058399b9b9a44c
diff --git a/dev-python/argh/argh-0.30.4.ebuild b/dev-python/argh/argh-0.30.4.ebuild
new file mode 100644
index 000000000000..32a100a7ba11
--- /dev/null
+++ b/dev-python/argh/argh-0.30.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A simple argparse wrapper"
+HOMEPAGE="
+ https://pythonhosted.org/argh/
+ https://github.com/neithere/argh/
+ https://pypi.org/project/argh/
+"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+LICENSE="LGPL-3"
+
+BDEPEND="
+ test? (
+ dev-python/iocapture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest