summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-30 18:16:09 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-30 18:18:48 +0200
commit0e562452fae2c7e25ffedf16371f5c0dc2b49d6d (patch)
tree41fa13a01b54d264b2576d6f1c37dcfb0ea40a69 /dev-python/anyio
parentdev-python/pytest-trio: Enable py3.12 (diff)
downloadgentoo-0e562452fae2c7e25ffedf16371f5c0dc2b49d6d.tar.gz
gentoo-0e562452fae2c7e25ffedf16371f5c0dc2b49d6d.tar.bz2
gentoo-0e562452fae2c7e25ffedf16371f5c0dc2b49d6d.zip
dev-python/anyio: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/anyio')
-rw-r--r--dev-python/anyio/anyio-3.7.0.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/anyio/anyio-3.7.0.ebuild b/dev-python/anyio/anyio-3.7.0.ebuild
index 3d11a37fec4e..ee80bbd44238 100644
--- a/dev-python/anyio/anyio-3.7.0.ebuild
+++ b/dev-python/anyio/anyio-3.7.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..11} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
inherit distutils-r1 pypi
@@ -59,6 +59,11 @@ python_test() {
'tests/test_taskgroups.py::test_exception_group_host[trio]'
'tests/test_taskgroups.py::test_exception_group_filtering[trio]'
)
+ if [[ ${EPYTHON} == python3.12 ]]; then
+ EPYTEST_DESELECT+=(
+ tests/test_fileio.py::TestPath::test_properties
+ )
+ fi
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest -m 'not network'