summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-02-09 22:50:54 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2023-02-10 00:26:27 +0100
commitc33b26139bdcab17fd76f0a3a5028b2f0b07eebc (patch)
tree876fc365bb3844cf6a1786d3a8916283cac4a9f1 /dev-python/aiocache
parentwww-client/vivaldi-snapshot: Drop old 5.7.2914.3 (diff)
downloadgentoo-c33b26139bdcab17fd76f0a3a5028b2f0b07eebc.tar.gz
gentoo-c33b26139bdcab17fd76f0a3a5028b2f0b07eebc.tar.bz2
gentoo-c33b26139bdcab17fd76f0a3a5028b2f0b07eebc.zip
dev-python/aiocache: new package, add 0.12.0
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'dev-python/aiocache')
-rw-r--r--dev-python/aiocache/Manifest1
-rw-r--r--dev-python/aiocache/aiocache-0.12.0.ebuild35
-rw-r--r--dev-python/aiocache/files/aiocache-0.12.0-fix-test-installation.patch12
-rw-r--r--dev-python/aiocache/metadata.xml16
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/aiocache/Manifest b/dev-python/aiocache/Manifest
new file mode 100644
index 000000000000..421a8f796e2c
--- /dev/null
+++ b/dev-python/aiocache/Manifest
@@ -0,0 +1 @@
+DIST aiocache-0.12.0.tar.gz 127002 BLAKE2B efb07ff146d777e99154c839d01665d35fbba410e1a1ca80d4c71f639e69abf43509d79398679027f0a94eb24cfdf933f5762418bd3f43dd441281cc1b1b5236 SHA512 8437c148cc2d40737c0352b0a2fa19636124b71bc03f206066e5c7b8910aa0f0bddfa40587d50a4acd86abd88e8db595a92e267d4b25234f20ccba94e5a63e7e
diff --git a/dev-python/aiocache/aiocache-0.12.0.ebuild b/dev-python/aiocache/aiocache-0.12.0.ebuild
new file mode 100644
index 000000000000..ac1baf19bf02
--- /dev/null
+++ b/dev-python/aiocache/aiocache-0.12.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Asyncio cache manager"
+HOMEPAGE="https://github.com/aio-libs/aiocache/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# TODO add optional cache systems deps (and new package aiomcache)
+# Tests require all backends
+RESTRICT="test"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=( "${FILESDIR}/${PN}-0.12.0-fix-test-installation.patch" )
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -o addopts=
+}
diff --git a/dev-python/aiocache/files/aiocache-0.12.0-fix-test-installation.patch b/dev-python/aiocache/files/aiocache-0.12.0-fix-test-installation.patch
new file mode 100644
index 000000000000..a64f618931ed
--- /dev/null
+++ b/dev-python/aiocache/files/aiocache-0.12.0-fix-test-installation.patch
@@ -0,0 +1,12 @@
+diff -Naur aiocache-0.12.0.orig/setup.py aiocache-0.12.0/setup.py
+--- aiocache-0.12.0.orig/setup.py 2023-01-13 21:54:07.000000000 +0100
++++ aiocache-0.12.0/setup.py 2023-02-09 22:45:48.004077571 +0100
+@@ -29,7 +29,7 @@
+ "Programming Language :: Python :: 3.11",
+ "Framework :: AsyncIO",
+ ],
+- packages=find_packages(),
++ packages=find_packages(exclude=['tests*']),
+ install_requires=None,
+ extras_require={
+ "redis": ["redis>=4.2.0"],
diff --git a/dev-python/aiocache/metadata.xml b/dev-python/aiocache/metadata.xml
new file mode 100644
index 000000000000..a54e1b0a7be8
--- /dev/null
+++ b/dev-python/aiocache/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>voyageur@gentoo.org</email>
+ <name>Bernard Cafarelli</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">aiocache</remote-id>
+ <remote-id type="github">aio-libs/aiocache</remote-id>
+ </upstream>
+</pkgmetadata>