summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-16 15:21:09 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-16 15:21:09 +0200
commit67092cdd97cc8b053adb5a42bcf6d7b19e12e4b7 (patch)
tree657a519824148d573ba34f62d9d5234e127528ee /dev-python/PySDL2
parentdev-python/pypugjs: Remove old (diff)
downloadgentoo-67092cdd97cc8b053adb5a42bcf6d7b19e12e4b7.tar.gz
gentoo-67092cdd97cc8b053adb5a42bcf6d7b19e12e4b7.tar.bz2
gentoo-67092cdd97cc8b053adb5a42bcf6d7b19e12e4b7.zip
dev-python/PySDL2: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/PySDL2')
-rw-r--r--dev-python/PySDL2/Manifest2
-rw-r--r--dev-python/PySDL2/PySDL2-0.9.10.ebuild55
-rw-r--r--dev-python/PySDL2/PySDL2-0.9.9.ebuild55
3 files changed, 0 insertions, 112 deletions
diff --git a/dev-python/PySDL2/Manifest b/dev-python/PySDL2/Manifest
index 3986d0fc6426..d604a9de88f7 100644
--- a/dev-python/PySDL2/Manifest
+++ b/dev-python/PySDL2/Manifest
@@ -1,3 +1 @@
-DIST PySDL2-0.9.10.tar.gz 5228778 BLAKE2B 1aac6ac3a33dd5cb56aad7e9fdcfe5ec62f7b406b9779aa04f92ec4f051cbe5f03596de06aa2d5688724c811c86959edefe40dab1e39980a8410c6b09c10c5ab SHA512 86517734d356ba7685914ce6e4583c8131bc2e84bf2318f985119407d39794878aeb8fdb84464e1e35c3b4cc1569777239dedb16f4669169f9f0302dacd8689e
DIST PySDL2-0.9.11.tar.gz 736026 BLAKE2B ebf5a98958681cc61155aeffdb67ca9d1aeef8143ca876b63772ce95b7bf23cc5708a01cfa83d3128d4fe20c2b714bf2f1e7dc64454c7d063590c55cfc236f24 SHA512 4e3383ef64f4f164d60a69a5a2c6ea153269b45661c9bba988d4c44a5cce7195cec0d29384d1855e9c9d507af2608bc808b9885449aea61c5ee51fc2d4f4af6f
-DIST PySDL2-0.9.9.tar.gz 743302 BLAKE2B 1e9e0eeea48b838227d3fe6ea93311d445b1d3a15588f4b83d075d18306b419ba3512826e44c5e4ecc2aec59ad44da73372ec740ebf6106271fd0b77175b88d7 SHA512 52b469735b1229392ea2f73b2dfcf1e75cedf7582a488461be9b06bc072f82a5c8c559d345a0c3668829c0f8bb2996005d538465ed7d2a45fb8480001fd0ccce
diff --git a/dev-python/PySDL2/PySDL2-0.9.10.ebuild b/dev-python/PySDL2/PySDL2-0.9.10.ebuild
deleted file mode 100644
index 08911e560403..000000000000
--- a/dev-python/PySDL2/PySDL2-0.9.10.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Python (ctypes) bindings for SDL2 libraries"
-HOMEPAGE="https://github.com/marcusva/py-sdl2 https://pypi.org/project/PySDL2/"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( public-domain CC0-1.0 ZLIB )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-# Optional deps:
-# - dev-python/numpy,
-# - dev-python/pillow,
-# - media-libs/sdl2-* (loaded dynamically via ctypes).
-#
-# If a reverse dependency needs the specific module, it should
-# explicitly depend on the optional module in question. You also
-# probably need to explicitly require some media-libs/libsdl2 flags.
-RDEPEND="media-libs/libsdl2"
-
-# Require all of SDL2 libraries and at least the most common subsystems
-# for better test coverage.
-DEPEND="
- test? (
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- media-libs/libsdl2[joystick,sound,video]
- media-libs/sdl2-gfx
- media-libs/sdl2-image[gif,jpeg,png,tiff,webp]
- || (
- media-libs/sdl2-mixer[flac]
- media-libs/sdl2-mixer[midi]
- media-libs/sdl2-mixer[mod]
- media-libs/sdl2-mixer[mp3]
- media-libs/sdl2-mixer[opus]
- )
- media-libs/sdl2-ttf
- )"
-
-distutils_enable_tests pytest
-
-src_test() {
- # from .travis.yml
- local -x SDL_VIDEODRIVER=dummy
- local -x SDL_AUDIODRIVER=dummy
- local -x SDL_RENDER_DRIVER=software
-
- distutils-r1_src_test
-}
diff --git a/dev-python/PySDL2/PySDL2-0.9.9.ebuild b/dev-python/PySDL2/PySDL2-0.9.9.ebuild
deleted file mode 100644
index e3b42a45db2c..000000000000
--- a/dev-python/PySDL2/PySDL2-0.9.9.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Python (ctypes) bindings for SDL2 libraries"
-HOMEPAGE="https://github.com/marcusva/py-sdl2 https://pypi.org/project/PySDL2/"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( public-domain CC0-1.0 ZLIB )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-# Optional deps:
-# - dev-python/numpy,
-# - dev-python/pillow,
-# - media-libs/sdl2-* (loaded dynamically via ctypes).
-#
-# If a reverse dependency needs the specific module, it should
-# explicitly depend on the optional module in question. You also
-# probably need to explicitly require some media-libs/libsdl2 flags.
-RDEPEND="media-libs/libsdl2"
-
-# Require all of SDL2 libraries and at least the most common subsystems
-# for better test coverage.
-DEPEND="
- test? (
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- media-libs/libsdl2[joystick,sound,video]
- media-libs/sdl2-gfx
- media-libs/sdl2-image[gif,jpeg,png,tiff,webp]
- || (
- media-libs/sdl2-mixer[flac]
- media-libs/sdl2-mixer[midi]
- media-libs/sdl2-mixer[mod]
- media-libs/sdl2-mixer[mp3]
- media-libs/sdl2-mixer[opus]
- )
- media-libs/sdl2-ttf
- )"
-
-distutils_enable_tests pytest
-
-src_test() {
- # from .travis.yml
- local -x SDL_VIDEODRIVER=dummy
- local -x SDL_AUDIODRIVER=dummy
- local -x SDL_RENDER_DRIVER=software
-
- distutils-r1_src_test
-}