summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-09-24 12:48:59 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-09-26 19:15:27 +0200
commitf780308080ec74211cb835c2ed45b376fb047c2d (patch)
tree219e3bd7a896cc89a0975b61e2a14a96ce409209 /dev-python/PyQtWebEngine
parentdev-python/PyQt5: drop 5.15.4-r1 (diff)
downloadgentoo-f780308080ec74211cb835c2ed45b376fb047c2d.tar.gz
gentoo-f780308080ec74211cb835c2ed45b376fb047c2d.tar.bz2
gentoo-f780308080ec74211cb835c2ed45b376fb047c2d.zip
dev-python/PyQtWebEngine: drop 5.15.4
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python/PyQtWebEngine')
-rw-r--r--dev-python/PyQtWebEngine/Manifest1
-rw-r--r--dev-python/PyQtWebEngine/PyQtWebEngine-5.15.4.ebuild74
2 files changed, 0 insertions, 75 deletions
diff --git a/dev-python/PyQtWebEngine/Manifest b/dev-python/PyQtWebEngine/Manifest
index 8ec2d4ebdc60..a58ca5ae35d1 100644
--- a/dev-python/PyQtWebEngine/Manifest
+++ b/dev-python/PyQtWebEngine/Manifest
@@ -1,2 +1 @@
-DIST PyQtWebEngine-5.15.4.tar.gz 49022 BLAKE2B 0ac0b3424f22aabbfd733f2a876e502f133c81f639fbd87a4c7509865635b29d4bd3596ccc151b0919a28eff0015913c4fae1a831dbe774fe2d2aeee732e469b SHA512 25cf8578ffae8adbc1dd8d914921b4edf91f19fcf983c9c83c9c8934b4e918ba27bd34a6b9c8252773ec32e6f1f13a06f22cf7d7326a5aceaa91530ea4ee047e
DIST PyQtWebEngine-5.15.5.tar.gz 48610 BLAKE2B ea266c09965a6ee62e33d3970b145068271c9e1eb87839782e0100b5db2e90a0c002fc4d6f3d22ef9a5cb8c42a067bb45008b0392a0d8557bc6c5c9d77e6b75a SHA512 20eecd479ea757e3bf9855c7dafe0bbbc0cbc61be26509605a5c9a8026e54bb6e362069ecf4be74733dcf6eec154f6ed13933e334e4455b080e687abfd2659fa
diff --git a/dev-python/PyQtWebEngine/PyQtWebEngine-5.15.4.ebuild b/dev-python/PyQtWebEngine/PyQtWebEngine-5.15.4.ebuild
deleted file mode 100644
index 91ec0ba948d2..000000000000
--- a/dev-python/PyQtWebEngine/PyQtWebEngine-5.15.4.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit python-r1 qmake-utils
-
-DESCRIPTION="Python bindings for QtWebEngine"
-HOMEPAGE="https://www.riverbankcomputing.com/software/pyqtwebengine/ https://pypi.org/project/PyQtWebEngine/"
-
-MY_P=${PN}-${PV/_pre/.dev}
-if [[ ${PV} == *_pre* ]]; then
- SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-fi
-S=${WORKDIR}/${MY_P}
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 x86"
-IUSE="debug"
-
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
-"
-
-RDEPEND="
- ${PYTHON_DEPS}
- ~dev-python/PyQt5-5.15.4[gui,network,printsupport,ssl,webchannel,widgets,${PYTHON_USEDEP}]
- >=dev-python/PyQt5-sip-4.19.22:=[${PYTHON_USEDEP}]
- dev-qt/qtcore:5
- dev-qt/qtwebengine:5[widgets]
-"
-DEPEND="${RDEPEND}
- >=dev-python/sip-4.19.22:0[${PYTHON_USEDEP}]
-"
-
-src_configure() {
- configuration() {
- local myconf=(
- "${EPYTHON}"
- "${S}"/configure.py
- --qmake="$(qt5_get_bindir)"/qmake
- $(usex debug '--debug --trace' '')
- --verbose
- )
- echo "${myconf[@]}"
- "${myconf[@]}" || die
-
- # Fix parallel install failure
- sed -i -e '/INSTALLS += distinfo/i distinfo.depends = install_subtargets install_pep484_stubs install_api' \
- ${PN}.pro || die
-
- # Run eqmake to respect toolchain and build flags
- eqmake5 -recursive ${PN}.pro
- }
- python_foreach_impl run_in_build_dir configuration
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir default
-}
-
-src_install() {
- installation() {
- emake INSTALL_ROOT="${D}" install
- python_optimize
- }
- python_foreach_impl run_in_build_dir installation
-
- einstalldocs
-}