summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-04-22 20:59:08 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-04-22 21:21:01 -0400
commitabe922769e4e6afd4c1b79c9a858a3aa894a147e (patch)
treef80babafd4f4bfeb33f6ea0c45e37061ca676611 /dev-python/PyQt6
parentdev-perl/IP-Country-DB_File: update test deps (diff)
downloadgentoo-abe922769e4e6afd4c1b79c9a858a3aa894a147e.tar.gz
gentoo-abe922769e4e6afd4c1b79c9a858a3aa894a147e.tar.bz2
gentoo-abe922769e4e6afd4c1b79c9a858a3aa894a147e.zip
dev-python/PyQt6: use binding operator for qtbase
Seems to rarely be an issue but hit symbol problems when using PyQt6-6.4.2 with Qt6.5 without a rebuild (otherwise works with 6.5 just fine). Could happen with 6.6+ too, albeit mitigated by PyQt6 bumps happening around same time and forcing the rebuild either way. Going to skip revbump for now given the above and being a slow build (plus it's masked), uncertain whether it'll even be needed for 6.6. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-python/PyQt6')
-rw-r--r--dev-python/PyQt6/PyQt6-6.4.2.ebuild3
-rw-r--r--dev-python/PyQt6/PyQt6-6.5.0.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/PyQt6/PyQt6-6.4.2.ebuild b/dev-python/PyQt6/PyQt6-6.4.2.ebuild
index 4e892b399454..2208a6968947 100644
--- a/dev-python/PyQt6/PyQt6-6.4.2.ebuild
+++ b/dev-python/PyQt6/PyQt6-6.4.2.ebuild
@@ -41,8 +41,9 @@ REQUIRED_USE="
websockets? ( network )
widgets? ( gui )"
+# can use parts of the Qt private api and "sometimes" needs rebuilds wrt :=
DEPEND="
- >=dev-qt/qtbase-${QT_PV}[dbus?,gles2-only=,gui?,network?,opengl?,sql?,ssl=,widgets?,xml?]
+ >=dev-qt/qtbase-${QT_PV}=[dbus?,gles2-only=,gui?,network?,opengl?,sql?,ssl=,widgets?,xml?]
dbus? (
dev-python/dbus-python[${PYTHON_USEDEP}]
sys-apps/dbus
diff --git a/dev-python/PyQt6/PyQt6-6.5.0.ebuild b/dev-python/PyQt6/PyQt6-6.5.0.ebuild
index 36a47c507bf3..e91c13b9dee8 100644
--- a/dev-python/PyQt6/PyQt6-6.5.0.ebuild
+++ b/dev-python/PyQt6/PyQt6-6.5.0.ebuild
@@ -42,8 +42,9 @@ REQUIRED_USE="
websockets? ( network )
widgets? ( gui )"
+# can use parts of the Qt private api and "sometimes" needs rebuilds wrt :=
DEPEND="
- >=dev-qt/qtbase-${QT_PV}[dbus?,gles2-only=,gui?,network?,opengl?,sql?,ssl=,widgets?,xml?]
+ >=dev-qt/qtbase-${QT_PV}=[dbus?,gles2-only=,gui?,network?,opengl?,sql?,ssl=,widgets?,xml?]
dbus? (
dev-python/dbus-python[${PYTHON_USEDEP}]
sys-apps/dbus