summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/pecl-memcache
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/pecl-memcache')
-rw-r--r--dev-php/pecl-memcache/Manifest2
-rw-r--r--dev-php/pecl-memcache/metadata.xml5
-rw-r--r--dev-php/pecl-memcache/pecl-memcache-2.2.7.ebuild43
-rw-r--r--dev-php/pecl-memcache/pecl-memcache-3.0.8-r1.ebuild46
-rw-r--r--dev-php/pecl-memcache/pecl-memcache-3.0.8.ebuild46
5 files changed, 142 insertions, 0 deletions
diff --git a/dev-php/pecl-memcache/Manifest b/dev-php/pecl-memcache/Manifest
new file mode 100644
index 000000000000..305f88cce4a4
--- /dev/null
+++ b/dev-php/pecl-memcache/Manifest
@@ -0,0 +1,2 @@
+DIST memcache-2.2.7.tgz 36459 SHA256 73006c02194a5a7c196c6488d449e5f8c75573a73568fe1a94b15157c147305d SHA512 cf02aad8005e501a3222bdd0829d0a1363ae322a11b656c9b3993a08fc74675f9afed48de7b0d1941d0daaa145d47a11b2ebf04f79c686fb27d11dddf29e10ea WHIRLPOOL d343c29f7f430053c82276e1049ac195d36af0fee58edd1a32a8b714bdad56ed67c6b6e8171429912ad4783768c6250d2fff4908b7e08dabebd2c8cd79aaf12f
+DIST memcache-3.0.8.tgz 70523 SHA256 2cae5b423ffbfd33a259829849f6000d4db018debe3e29ecf3056f06642e8311 SHA512 916c6b21ab7c1021128626c0df35ef0b83cb76b6115fe7c45b003ca4f78ad9484bf3c998bc7ebdee19f84349ff1e56759f74e75aee5bc70b1de9a03c45a99bc3 WHIRLPOOL 72a88736e53453cbf8b1c8f7aa39f4f144ab363b915c6fe641aee5c6f0ab46bf4dabdc5c8ef9e66ba186a4f38533a3e4ad336743cdc2bd3253794e697cfd418e
diff --git a/dev-php/pecl-memcache/metadata.xml b/dev-php/pecl-memcache/metadata.xml
new file mode 100644
index 000000000000..fd3dbe39fa64
--- /dev/null
+++ b/dev-php/pecl-memcache/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php/pecl-memcache/pecl-memcache-2.2.7.ebuild b/dev-php/pecl-memcache/pecl-memcache-2.2.7.ebuild
new file mode 100644
index 000000000000..4707b3e03c58
--- /dev/null
+++ b/dev-php/pecl-memcache/pecl-memcache-2.2.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PHP_EXT_NAME="memcache"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README"
+
+USE_PHP="php5-6 php5-5 php5-4"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64 ~hppa ~ppc64 ~x86"
+
+DESCRIPTION="PHP extension for using memcached"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE="+session"
+
+DEPEND="sys-libs/zlib
+ dev-lang/php:*[session?]"
+RDEPEND="${DEPEND}"
+
+# upstream does not ship any testsuite, so the PHPize test-runner fails.
+RESTRICT='test'
+
+src_configure() {
+ my_conf="--enable-memcache --with-zlib-dir=/usr $(use_enable session memcache-session)"
+ php-ext-source-r2_src_configure
+}
+
+src_install() {
+ php-ext-pecl-r2_src_install
+
+ php-ext-source-r2_addtoinifiles "memcache.allow_failover" "true"
+ php-ext-source-r2_addtoinifiles "memcache.max_failover_attempts" "20"
+ php-ext-source-r2_addtoinifiles "memcache.chunk_size" "32768"
+ php-ext-source-r2_addtoinifiles "memcache.default_port" "11211"
+ php-ext-source-r2_addtoinifiles "memcache.hash_strategy" "standard"
+ php-ext-source-r2_addtoinifiles "memcache.hash_function" "crc32"
+}
diff --git a/dev-php/pecl-memcache/pecl-memcache-3.0.8-r1.ebuild b/dev-php/pecl-memcache/pecl-memcache-3.0.8-r1.ebuild
new file mode 100644
index 000000000000..cdf98be4f8db
--- /dev/null
+++ b/dev-php/pecl-memcache/pecl-memcache-3.0.8-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PHP_EXT_NAME="memcache"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README"
+
+USE_PHP="php5-6 php5-5 php5-4"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="amd64 hppa ppc64 x86"
+
+DESCRIPTION="PHP extension for using memcached"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE="+session"
+
+DEPEND="sys-libs/zlib
+ dev-lang/php:*[session?]"
+RDEPEND="${DEPEND}"
+
+# The test suite requires memcached to be running.
+RESTRICT='test'
+
+src_configure() {
+ my_conf="--enable-memcache --with-zlib-dir=/usr $(use_enable session memcache-session)"
+ php-ext-source-r2_src_configure
+}
+
+src_install() {
+ php-ext-pecl-r2_src_install
+
+ php-ext-source-r2_addtoinifiles "memcache.allow_failover" "true"
+ php-ext-source-r2_addtoinifiles "memcache.max_failover_attempts" "20"
+ php-ext-source-r2_addtoinifiles "memcache.chunk_size" "32768"
+ php-ext-source-r2_addtoinifiles "memcache.default_port" "11211"
+ php-ext-source-r2_addtoinifiles "memcache.hash_strategy" "consistent"
+ php-ext-source-r2_addtoinifiles "memcache.hash_function" "crc32"
+ php-ext-source-r2_addtoinifiles "memcache.redundancy" "1"
+ php-ext-source-r2_addtoinifiles "memcache.session_redundancy" "2"
+ php-ext-source-r2_addtoinifiles "memcache.protocol" "ascii"
+}
diff --git a/dev-php/pecl-memcache/pecl-memcache-3.0.8.ebuild b/dev-php/pecl-memcache/pecl-memcache-3.0.8.ebuild
new file mode 100644
index 000000000000..ef3b70ee2346
--- /dev/null
+++ b/dev-php/pecl-memcache/pecl-memcache-3.0.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PHP_EXT_NAME="memcache"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README"
+
+USE_PHP="php5-5 php5-4"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="amd64 hppa ppc64 x86"
+
+DESCRIPTION="PHP extension for using memcached"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE="+session"
+
+DEPEND="sys-libs/zlib
+ dev-lang/php:*[session?]"
+RDEPEND="${DEPEND}"
+
+# upstream does not ship any testsuite, so the PHPize test-runner fails.
+RESTRICT='test'
+
+src_configure() {
+ my_conf="--enable-memcache --with-zlib-dir=/usr $(use_enable session memcache-session)"
+ php-ext-source-r2_src_configure
+}
+
+src_install() {
+ php-ext-pecl-r2_src_install
+
+ php-ext-source-r2_addtoinifiles "memcache.allow_failover" "true"
+ php-ext-source-r2_addtoinifiles "memcache.max_failover_attempts" "20"
+ php-ext-source-r2_addtoinifiles "memcache.chunk_size" "32768"
+ php-ext-source-r2_addtoinifiles "memcache.default_port" "11211"
+ php-ext-source-r2_addtoinifiles "memcache.hash_strategy" "consistent"
+ php-ext-source-r2_addtoinifiles "memcache.hash_function" "crc32"
+ php-ext-source-r2_addtoinifiles "memcache.redundancy" "1"
+ php-ext-source-r2_addtoinifiles "memcache.session_redundancy" "2"
+ php-ext-source-r2_addtoinifiles "memcache.protocol" "ascii"
+}