summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/magickwand
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/magickwand')
-rw-r--r--dev-php/magickwand/Manifest1
-rw-r--r--dev-php/magickwand/files/imagemagick-pre-6.3.8-compat.patch72
-rw-r--r--dev-php/magickwand/magickwand-1.0.9-r1.ebuild30
-rw-r--r--dev-php/magickwand/metadata.xml9
4 files changed, 112 insertions, 0 deletions
diff --git a/dev-php/magickwand/Manifest b/dev-php/magickwand/Manifest
new file mode 100644
index 000000000000..d4f5365faa95
--- /dev/null
+++ b/dev-php/magickwand/Manifest
@@ -0,0 +1 @@
+DIST MagickWandForPHP-1.0.9-2.tar.bz2 123894 SHA256 05e5fe5bc52ab9169228bbbde38b222208d1ae19db718b66d2c7ac4180847727 SHA512 67965bd5576b84786b149b64f807fc5f629cfd223013acf83823ffa168571fa5c8f264e15be2ee1c64f68250690dc60c285c6c3c8b8ce3b826b1303f4a29caef WHIRLPOOL 07be727899340b2df28ebe13ad7cdcea9f029885e397f96554ef7030769320dfd55c249851962ecc31db9a432a4d36a0331349e6527b315dc3d1838c80ed3e78
diff --git a/dev-php/magickwand/files/imagemagick-pre-6.3.8-compat.patch b/dev-php/magickwand/files/imagemagick-pre-6.3.8-compat.patch
new file mode 100644
index 000000000000..b8634304ed15
--- /dev/null
+++ b/dev-php/magickwand/files/imagemagick-pre-6.3.8-compat.patch
@@ -0,0 +1,72 @@
+# allow usage of <imagemagick-6.3.8, bug 215671
+# patch by Martin von Gagern <Martin.vGagern@gmx.net>
+
+--- MagickWandForPHP-1.0.7-1/config.m4 2008-04-13 19:30:55.000000000 +0200
++++ MagickWandForPHP-1.0.7/config.m4 2008-06-10 11:34:24.000000000 +0200
+@@ -3,30 +3,30 @@
+
+ if test $PHP_MAGICKWAND != "no"; then
+
+- if test -r $PHP_MAGICKWAND/bin/MagickWand-config; then
++ if test -r $PHP_MAGICKWAND/bin/Wand-config; then
+ WAND_CONFIG_PATH=$PHP_MAGICKWAND/bin
+ else
+- AC_MSG_CHECKING(MagickWand-config in default path)
++ AC_MSG_CHECKING(Wand-config in default path)
+
+ for i in /usr/local /usr;
+ do
+- test -r $i/bin/MagickWand-config && WAND_CONFIG_PATH=$i/bin && break
++ test -r $i/bin/Wand-config && WAND_CONFIG_PATH=$i/bin && break
+ done
+
+ if test -z "$WAND_CONFIG_PATH"; then
+ for i in $PHP_MAGICKWAND /usr/local /usr;
+ do
+- test -r $i/MagickWand-config && WAND_CONFIG_PATH=$i && break
++ test -r $i/Wand-config && WAND_CONFIG_PATH=$i && break
+ done
+ fi
+ if test -z "$WAND_CONFIG_PATH"; then
+- AC_MSG_ERROR(Cannot locate configuration program MagickWand-config)
++ AC_MSG_ERROR(Cannot locate configuration program Wand-config)
+ else
+ AC_MSG_RESULT(found in $WAND_CONFIG_PATH)
+ fi
+ fi
+
+- IMAGEMAGICK_VERSION_ORIG=`$WAND_CONFIG_PATH/MagickWand-config --version`
++ IMAGEMAGICK_VERSION_ORIG=`$WAND_CONFIG_PATH/Wand-config --version`
+ IMAGEMAGICK_VERSION_MASK=`echo ${IMAGEMAGICK_VERSION_ORIG} | awk 'BEGIN { FS = "."; } { printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
+
+
+@@ -34,7 +34,7 @@
+ if test "$IMAGEMAGICK_VERSION_MASK" -ge 6003005; then
+ AC_MSG_RESULT(found version $IMAGEMAGICK_VERSION_ORIG)
+ else
+- AC_MSG_ERROR(no. You need at least ImageMagick version 6.3.8 to use MagickWand for PHP.)
++ AC_MSG_ERROR(no. You need at least ImageMagick version 6.3.5 to use MagickWand for PHP.)
+ fi
+
+ AC_MSG_CHECKING(if PHP version is at least 4.1.3)
+@@ -63,16 +63,13 @@
+
+ AC_DEFINE(HAVE_MAGICKWAND,1,[ ])
+
+- PHP_ADD_LIBRARY_WITH_PATH(MagickCore, $WAND_DIR/lib, MAGICKWAND_SHARED_LIBADD)
+- PHP_ADD_LIBRARY_WITH_PATH(MagickWand, $WAND_DIR/lib, MAGICKWAND_SHARED_LIBADD)
+- PHP_ADD_INCLUDE($WAND_DIR/include/ImageMagick)
+- AC_MSG_CHECKING(MagickWand-config --cppflags)
+- WAND_CPPFLAGS="`$WAND_CONFIG_PATH/MagickWand-config --cppflags`"
++ AC_MSG_CHECKING(Wand-config --cppflags)
++ WAND_CPPFLAGS="`$WAND_CONFIG_PATH/Wand-config --cppflags`"
+ AC_MSG_RESULT($WAND_CPPFLAGS)
+ PHP_EVAL_INCLINE($WAND_CPPFLAGS)
+
+- AC_MSG_CHECKING(MagickWand-config --libs)
+- WAND_LIBS="`$WAND_CONFIG_PATH/MagickWand-config --libs`"
++ AC_MSG_CHECKING(Wand-config --libs)
++ WAND_LIBS="`$WAND_CONFIG_PATH/Wand-config --libs`"
+ AC_MSG_RESULT($WAND_LIBS)
+ PHP_EVAL_LIBLINE($WAND_LIBS, MAGICKWAND_SHARED_LIBADD)
+
diff --git a/dev-php/magickwand/magickwand-1.0.9-r1.ebuild b/dev-php/magickwand/magickwand-1.0.9-r1.ebuild
new file mode 100644
index 000000000000..eefe2c9a10f5
--- /dev/null
+++ b/dev-php/magickwand/magickwand-1.0.9-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PHP_EXT_NAME="magickwand"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_INI="yes"
+DOCS="AUTHOR ChangeLog CREDITS README TODO"
+
+MY_PN="MagickWandForPHP"
+IUSE=""
+
+USE_PHP="php5-6 php5-5 php5-4"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+inherit php-ext-source-r2
+
+DESCRIPTION="A native PHP-extension to the ImageMagick MagickWand API"
+HOMEPAGE="http://www.magickwand.org/"
+SRC_URI="http://www.magickwand.org/download/php/${MY_PN}-${PV}-2.tar.bz2"
+
+LICENSE="MagickWand"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=media-gfx/imagemagick-6.5.2.9"
+RDEPEND="${DEPEND}"
diff --git a/dev-php/magickwand/metadata.xml b/dev-php/magickwand/metadata.xml
new file mode 100644
index 000000000000..5c3dc463d770
--- /dev/null
+++ b/dev-php/magickwand/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+ <longdescription>
+ This PHP5 extension provides
+ access to the ImageMagick MagickWand API.
+ </longdescription>
+</pkgmetadata>