summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-04-23 10:36:08 -0400
committerBrian Evans <grknight@gentoo.org>2018-04-23 10:54:00 -0400
commitd516852f3caa39014fa47d3f9da335e715456454 (patch)
treec000633f6f50b4d751640b11ca183fb8389efe91 /dev-php/PEAR-HTTP_Session2
parentdev-php/PEAR-HTTP_Request2: Fix data file path (diff)
downloadgentoo-d516852f3caa39014fa47d3f9da335e715456454.tar.gz
gentoo-d516852f3caa39014fa47d3f9da335e715456454.tar.bz2
gentoo-d516852f3caa39014fa47d3f9da335e715456454.zip
dev-php/PEAR-HTTP_Session2: Revbump for EAPI and tests
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'dev-php/PEAR-HTTP_Session2')
-rw-r--r--dev-php/PEAR-HTTP_Session2/PEAR-HTTP_Session2-0.7.3-r2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-php/PEAR-HTTP_Session2/PEAR-HTTP_Session2-0.7.3-r2.ebuild b/dev-php/PEAR-HTTP_Session2/PEAR-HTTP_Session2-0.7.3-r2.ebuild
new file mode 100644
index 000000000000..2a2f0882b48d
--- /dev/null
+++ b/dev-php/PEAR-HTTP_Session2/PEAR-HTTP_Session2-0.7.3-r2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+DESCRIPTION="Wraps PHP's session functions providing extras like db storage for session data"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal test"
+
+RDEPEND="!minimal? ( >=dev-php/PEAR-MDB2-2.4.1
+ >=dev-php/PEAR-DB-1.7.11 )"
+DEPEND="test? ( dev-php/PEAR-PEAR )"
+
+src_test() {
+ pear run-tests tests || die "Tests failed"
+}