summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Try-Tiny
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Try-Tiny')
-rw-r--r--dev-perl/Try-Tiny/Manifest2
-rw-r--r--dev-perl/Try-Tiny/Try-Tiny-0.180.0.ebuild20
-rw-r--r--dev-perl/Try-Tiny/Try-Tiny-0.190.0.ebuild25
-rw-r--r--dev-perl/Try-Tiny/metadata.xml9
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-perl/Try-Tiny/Manifest b/dev-perl/Try-Tiny/Manifest
new file mode 100644
index 000000000000..9e103b40c08a
--- /dev/null
+++ b/dev-perl/Try-Tiny/Manifest
@@ -0,0 +1,2 @@
+DIST Try-Tiny-0.18.tar.gz 16499 SHA256 4ec6fa76eda43ceb10598ea9950c815b332bb4e927b11a62d247c447faca4a1a SHA512 2e21298a22670c58a702a5a168a43dc48a213ef407bd7be3b3676522ea17735ea22dc835aa89c4e57e53af030e3310c881e9432c527435d827351f2230af0de5 WHIRLPOOL 5822a52848a4716cbbe882d95e11e9ff486a4fd6c29d1601c00bfcce0e3517bba54e281308acf539c47df6708a7abb869a5c3bad2432c8ee10877e3414a9ea83
+DIST Try-Tiny-0.19.tar.gz 17165 SHA256 57ae3341b03af36a052922d88e1ebf1c17828b25da69dfbe98ac8b113c181aec SHA512 5a642da7e55becb41109bfbb1e44999bde6904c4c5b961658b3ddb5958c84320f02ba7e081f36e7381dd04ae7174373e0c69587f49882b35202e8a45f6eb5115 WHIRLPOOL 6398d05e865b6c155ff9774f72ea6e2b0610d1968750a0d3d41687dedbc10930cf9a15de15fb739f5ca4f0c048879ee00479986ec1ebec48bd54c6ea2dc3661c
diff --git a/dev-perl/Try-Tiny/Try-Tiny-0.180.0.ebuild b/dev-perl/Try-Tiny/Try-Tiny-0.180.0.ebuild
new file mode 100644
index 000000000000..cfee4ec702da
--- /dev/null
+++ b/dev-perl/Try-Tiny/Try-Tiny-0.180.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DOY
+MODULE_VERSION=0.18
+inherit perl-module
+
+DESCRIPTION="Minimal try/catch with proper localization of $@"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+DEPEND="test? ( dev-perl/Sub-Name )"
+
+SRC_TEST=do
diff --git a/dev-perl/Try-Tiny/Try-Tiny-0.190.0.ebuild b/dev-perl/Try-Tiny/Try-Tiny-0.190.0.ebuild
new file mode 100644
index 000000000000..a2fb3cdcd641
--- /dev/null
+++ b/dev-perl/Try-Tiny/Try-Tiny-0.190.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DOY
+MODULE_VERSION=0.19
+inherit perl-module
+
+DESCRIPTION="Minimal try/catch with proper localization of $@"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-perl/Sub-Name
+ dev-perl/Capture-Tiny
+ )
+"
+
+SRC_TEST=do
diff --git a/dev-perl/Try-Tiny/metadata.xml b/dev-perl/Try-Tiny/metadata.xml
new file mode 100644
index 000000000000..67a411aa7a69
--- /dev/null
+++ b/dev-perl/Try-Tiny/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Try-Tiny</remote-id>
+ <remote-id type="cpan-module">Try::Tiny</remote-id>
+ </upstream>
+</pkgmetadata>