summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-12 09:04:53 +0100
committerSam James <sam@gentoo.org>2023-07-12 09:45:39 +0100
commitd302f8ad301a15d31e408cb8fafac60e89f4c4e9 (patch)
tree600d8546cafa94ef0d5adbec0233930569f5fd35 /dev-perl/Test-Compile
parentdev-perl/HTML-Quoted: add 0.50.0 (diff)
downloadgentoo-d302f8ad301a15d31e408cb8fafac60e89f4c4e9.tar.gz
gentoo-d302f8ad301a15d31e408cb8fafac60e89f4c4e9.tar.bz2
gentoo-d302f8ad301a15d31e408cb8fafac60e89f4c4e9.zip
dev-perl/Test-Compile: add 3.3.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Test-Compile')
-rw-r--r--dev-perl/Test-Compile/Manifest1
-rw-r--r--dev-perl/Test-Compile/Test-Compile-3.3.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/Test-Compile/Manifest b/dev-perl/Test-Compile/Manifest
index dd4baee2edf1..fba86c90a405 100644
--- a/dev-perl/Test-Compile/Manifest
+++ b/dev-perl/Test-Compile/Manifest
@@ -1,3 +1,4 @@
DIST Test-Compile-v2.4.2.tar.gz 18842 BLAKE2B 6bc8dbd692087ccbf41b227c417f1cb8a100ea2e845289fae52ce8f375c4f7970f759ab2fffcb19af7670ec93f92115812184d9d71f73db21628b4937b6e84c9 SHA512 3c16249d9cf14c3cc1dae5958c591b9beac320e26c3ef958a76ca74763ce30443ebe55e3e4efacd384252dfe1ef1cfca9c12d4f7a67780e0db20d6462b6d541c
DIST Test-Compile-v3.0.1.tar.gz 18490 BLAKE2B d472567065549a6a00c668aa5d7af1597f5d3fe0f06a849b374fe0b6757ef5a591ddb5834c894c64c48d9eabe5112803509dba9b4698afed6e028a5010ae4b5f SHA512 a8e5d0fabaaa0c8d4de716da85279c8d4abdcfb8e453159f5b47d10e1845d2f80164d099bcd3906d74afae1137fd9d4430d47b8bdcb3afc6d81b8043bd585715
DIST Test-Compile-v3.2.2.tar.gz 19612 BLAKE2B e6a14624c1aaf70e5228d46ed33313e07ecfd2632ef8e369c2046317dac5ff83f48efe853f06436d71b98721cb8f5b5e6354a4d62c67351297b512a1be1152a7 SHA512 68a18cee66cc8eb2bf10b3d7f97244ee49d7162284957a8f34226846f3afda1872c809b4cdd7494286afea255313eeba27f392e3827ed127d39bbdf406be8151
+DIST Test-Compile-v3.3.0.tar.gz 20143 BLAKE2B 701b72181807a44bb46944e0e505644521b10b16a4180e6f4e1ce3a2e41a185a4471e9bc9b1d1e8aefd6485d5db898fa408dd7f09fff22ff7d33f980898a2123 SHA512 41c05d70e2913905d886651e1f882bd145c0f4c9ed433e8541cb9cf33e622f7c34ebe5c9eb875161782cf8a7bafc6bdc2f03b60c8bbef7f9ff0381d833f5205a
diff --git a/dev-perl/Test-Compile/Test-Compile-3.3.0.ebuild b/dev-perl/Test-Compile/Test-Compile-3.3.0.ebuild
new file mode 100644
index 000000000000..7577d8d71c55
--- /dev/null
+++ b/dev-perl/Test-Compile/Test-Compile-3.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=EGILES
+DIST_VERSION=v${PV}
+inherit perl-module
+
+DESCRIPTION="Check whether Perl files compile correctly"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+ >=virtual/perl-Exporter-5.680.0
+ >=virtual/perl-parent-0.225.0
+ >=virtual/perl-version-0.770.0
+"
+BDEPEND="
+ ${RDEPEND}
+ >=dev-perl/Module-Build-0.380.0
+ test? (
+ dev-perl/Test-Exception
+ dev-perl/Test-Warnings
+ virtual/perl-Test-Simple
+ )
+"
+
+PERL_RM_FILES=(
+ t/999-has-version.t
+ t/999-perlcritic.t
+ t/999-pod-coverage.t
+ t/999-pod.t
+ t/999-portability.t
+ t/999-synopsis.t
+ t/999-version.t
+)