summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-08-16 23:04:57 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-08-16 23:11:55 +0200
commit08182ed46b28901a65aaca902b8d1e8454e511c6 (patch)
tree4f9662fccf322892c94d561f8fa128e46e4922c0 /dev-perl/Test-Compile
parentdev-perl/Test-Command-Simple: EAPI=8 bump (diff)
downloadgentoo-08182ed46b28901a65aaca902b8d1e8454e511c6.tar.gz
gentoo-08182ed46b28901a65aaca902b8d1e8454e511c6.tar.bz2
gentoo-08182ed46b28901a65aaca902b8d1e8454e511c6.zip
dev-perl/Test-Compile: Version bump 2.4.2
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Test-Compile')
-rw-r--r--dev-perl/Test-Compile/Manifest1
-rw-r--r--dev-perl/Test-Compile/Test-Compile-2.4.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-perl/Test-Compile/Manifest b/dev-perl/Test-Compile/Manifest
index 988c943291aa..a9f30a67e01f 100644
--- a/dev-perl/Test-Compile/Manifest
+++ b/dev-perl/Test-Compile/Manifest
@@ -1 +1,2 @@
DIST Test-Compile-v2.4.1.tar.gz 18425 BLAKE2B 604626b07772241f0ab306b06de70223a25673fe944e66c1c031dfe0e55610f7ce1cc0222bfc839331b2f10bd63168100b9e07b1013dc8ca96d03bd53848d3dd SHA512 e6878fa16544be75581144d125f547a799cc79210b925b86f07ad236395026bdc197c22af1820e893f5887e53933f0ba827377ae133752f63076cb436b624aee
+DIST Test-Compile-v2.4.2.tar.gz 18842 BLAKE2B 6bc8dbd692087ccbf41b227c417f1cb8a100ea2e845289fae52ce8f375c4f7970f759ab2fffcb19af7670ec93f92115812184d9d71f73db21628b4937b6e84c9 SHA512 3c16249d9cf14c3cc1dae5958c591b9beac320e26c3ef958a76ca74763ce30443ebe55e3e4efacd384252dfe1ef1cfca9c12d4f7a67780e0db20d6462b6d541c
diff --git a/dev-perl/Test-Compile/Test-Compile-2.4.2.ebuild b/dev-perl/Test-Compile/Test-Compile-2.4.2.ebuild
new file mode 100644
index 000000000000..80add0a69915
--- /dev/null
+++ b/dev-perl/Test-Compile/Test-Compile-2.4.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=EGILES
+DIST_VERSION=v${PV}
+inherit perl-module
+
+DESCRIPTION="Check whether Perl files compile correctly"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="minimal"
+
+RDEPEND="
+ !minimal? (
+ dev-perl/Devel-CheckOS
+ )
+ >=virtual/perl-Exporter-5.680.0
+ dev-perl/UNIVERSAL-require
+ >=virtual/perl-parent-0.225.0
+ virtual/perl-version
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.380.0
+ test? (
+ dev-perl/Test-Exception
+ dev-perl/Test-Warnings
+ virtual/perl-Test-Simple
+ )
+"
+
+PERL_RM_FILES=(
+ t/999-has-version.t
+ t/999-perlcritic.t
+ t/999-pod-coverage.t
+ t/999-pod.t
+ t/999-portability.t
+ t/999-synopsis.t
+ t/999-version.t
+)