summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/JSON-RPC
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/JSON-RPC')
-rw-r--r--dev-perl/JSON-RPC/JSON-RPC-0.960.0-r1.ebuild21
-rw-r--r--dev-perl/JSON-RPC/JSON-RPC-1.30.0-r1.ebuild32
-rw-r--r--dev-perl/JSON-RPC/Manifest2
-rw-r--r--dev-perl/JSON-RPC/metadata.xml25
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-perl/JSON-RPC/JSON-RPC-0.960.0-r1.ebuild b/dev-perl/JSON-RPC/JSON-RPC-0.960.0-r1.ebuild
new file mode 100644
index 000000000000..3fc83d4acada
--- /dev/null
+++ b/dev-perl/JSON-RPC/JSON-RPC-0.960.0-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MAKAMAKA
+MODULE_VERSION=0.96
+inherit perl-module
+
+DESCRIPTION="Perl implementation of JSON-RPC 1.1 protocol"
+
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="dev-perl/libwww-perl
+ >=dev-perl/JSON-2.21"
+DEPEND="${RDEPEND}"
+
+SRC_TEST="do"
diff --git a/dev-perl/JSON-RPC/JSON-RPC-1.30.0-r1.ebuild b/dev-perl/JSON-RPC/JSON-RPC-1.30.0-r1.ebuild
new file mode 100644
index 000000000000..4d2bbb182a19
--- /dev/null
+++ b/dev-perl/JSON-RPC/JSON-RPC-1.30.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DMAKI
+MODULE_VERSION=1.03
+inherit perl-module
+
+DESCRIPTION="JSON RPC 2.0 Server Implementation"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Class-Accessor-Lite
+ dev-perl/libwww-perl
+ >=dev-perl/JSON-2.21
+ dev-perl/Plack
+ dev-perl/Router-Simple
+ dev-perl/Try-Tiny
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/Test-Pod
+ )
+"
+
+SRC_TEST="do"
+pm_echovar="y"
diff --git a/dev-perl/JSON-RPC/Manifest b/dev-perl/JSON-RPC/Manifest
new file mode 100644
index 000000000000..967788d3d4f1
--- /dev/null
+++ b/dev-perl/JSON-RPC/Manifest
@@ -0,0 +1,2 @@
+DIST JSON-RPC-0.96.tar.gz 14206 SHA256 043624b5bd8a9eef18fd03082a1d99b45e3c5202786752a32e051590b565ba15 SHA512 2137d8d645c672fc176acc7c8b8dc50f6fc7215fcecc8c6465ddac9e1c4cffdf8f04d0a8222267cfb5ac79c04448444d6aa7ca1beac96c809986569f79cec6c9 WHIRLPOOL c2f2b9ff91d533b09c2fb151acb7ea9eadcd622623ec8af9154b9b41e866942d1f31fd05f55b86f77f217ed7b2bbdb600771f97fcb264e7faa2ed3aae3bf89e4
+DIST JSON-RPC-1.03.tar.gz 37495 SHA256 b564005ab9b74309e10fca7fc14cf133d3b5c38a8a9f63d8f4d50eef45033290 SHA512 5fc0a63a35ab6162d3ae70bbc9f26e556a270fe5c1225ff614f8bdd6d9bf0095fcc85ff3b942d4e09ee35ed52c2f5bfbfb25f28a885192c230d5a35cd9446103 WHIRLPOOL dcc4bb79d899b3a2e0e68b5e37f1e1214c5a9c745c3816d382c36fa3ac74b134b5ca291d89d52314ab5da939af0c30a70d5c1b40129a40127b742393e24ab4cb
diff --git a/dev-perl/JSON-RPC/metadata.xml b/dev-perl/JSON-RPC/metadata.xml
new file mode 100644
index 000000000000..f98b8b111dfe
--- /dev/null
+++ b/dev-perl/JSON-RPC/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">JSON-RPC</remote-id>
+ <remote-id type="cpan-module">JSON::RPC</remote-id>
+ <remote-id type="cpan-module">JSON::RPC::Constants</remote-id>
+ <remote-id type="cpan-module">JSON::RPC::Dispatch</remote-id>
+ <remote-id type="cpan-module">JSON::RPC::Legacy</remote-id>
+ <remote-id type="cpan-module">JSON::RPC::Legacy::Client</remote-id>
+ <remote-id type="cpan-module">JSON::RPC::Legacy::Procedure</remote-id>
+ <remote-id type="cpan-module">JSON::RPC::Legacy::ReturnObject</remote-id>
+ <remote-id type="cpan-module">JSON::RPC::Legacy::Server</remote-id>
+ <remote-id type="cpan-module">JSON::RPC::Legacy::Server::Apache</remote-id>
+ <remote-id type="cpan-module">JSON::RPC::Legacy::Server::Apache2</remote-id>
+ <remote-id type="cpan-module">JSON::RPC::Legacy::Server::CGI</remote-id>
+ <remote-id type="cpan-module">JSON::RPC::Legacy::Server::Daemon</remote-id>
+ <remote-id type="cpan-module">JSON::RPC::Legacy::Server::system</remote-id>
+ <remote-id type="cpan-module">JSON::RPC::Legacy::ServiceObject</remote-id>
+ <remote-id type="cpan-module">JSON::RPC::Parser</remote-id>
+ <remote-id type="cpan-module">JSON::RPC::Procedure</remote-id>
+ <remote-id type="cpan-module">JSON::RPC::Test</remote-id>
+ </upstream>
+</pkgmetadata>