summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-18 23:06:33 +0200
committerDavid Seifert <soap@gentoo.org>2021-06-18 23:06:33 +0200
commitf0da870f170fa4a22b31fba321416cf35d43f6fa (patch)
tree9e6b279f12acb398a83d89d1783a43e9dc9660e5 /dev-perl/Filesys-SmbClient
parentsci-libs/tensorflow: add pkgconfig or pkgconfig-referenced libs deps (diff)
downloadgentoo-f0da870f170fa4a22b31fba321416cf35d43f6fa.tar.gz
gentoo-f0da870f170fa4a22b31fba321416cf35d43f6fa.tar.bz2
gentoo-f0da870f170fa4a22b31fba321416cf35d43f6fa.zip
dev-perl/Filesys-SmbClient: respect ${PKG_CONFIG}
Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-perl/Filesys-SmbClient')
-rw-r--r--dev-perl/Filesys-SmbClient/Filesys-SmbClient-3.200.0-r4.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-perl/Filesys-SmbClient/Filesys-SmbClient-3.200.0-r4.ebuild b/dev-perl/Filesys-SmbClient/Filesys-SmbClient-3.200.0-r4.ebuild
index adf20536a0e7..adf0d3316b03 100644
--- a/dev-perl/Filesys-SmbClient/Filesys-SmbClient-3.200.0-r4.ebuild
+++ b/dev-perl/Filesys-SmbClient/Filesys-SmbClient-3.200.0-r4.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DIST_AUTHOR=ALIAN
DIST_VERSION=3.2
-inherit perl-module autotools
+inherit perl-module autotools toolchain-funcs
DESCRIPTION="Provide Perl API for libsmbclient.so"
@@ -36,8 +36,8 @@ src_prepare() {
eautoreconf
}
src_configure() {
- GENTOO_INC_SMBCLIENT="$( pkg-config --variable=includedir smbclient )" \
- GENTOO_LIB_SMBCLIENT="$( pkg-config --variable=libdir smbclient )" \
+ GENTOO_INC_SMBCLIENT="$( $(tc-getPKG_CONFIG) --variable=includedir smbclient )" \
+ GENTOO_LIB_SMBCLIENT="$( $(tc-getPKG_CONFIG) --variable=libdir smbclient )" \
perl-module_src_configure
}
src_compile() {