summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Huettel (dilfridge) <dilfridge@gentoo.org>2015-11-23 00:00:17 +0100
committerAndreas K. Huettel (dilfridge) <dilfridge@gentoo.org>2015-11-23 00:00:48 +0100
commit531c146bbc11879bee4645fd6fb3c1b2223fa924 (patch)
tree66707bd391d914ae15ace798c3b1c7efd8c8cc92 /dev-perl/DBD-mysql/DBD-mysql-4.32.0-r1.ebuild
parentqmake-utils.eclass: stop inheriting unneeded multilib in EAPI 6 (diff)
downloadgentoo-531c146bbc11879bee4645fd6fb3c1b2223fa924.tar.gz
gentoo-531c146bbc11879bee4645fd6fb3c1b2223fa924.tar.bz2
gentoo-531c146bbc11879bee4645fd6fb3c1b2223fa924.zip
dev-perl/DBD-mysql: Fix test logic
Package-Manager: portage-2.2.25
Diffstat (limited to 'dev-perl/DBD-mysql/DBD-mysql-4.32.0-r1.ebuild')
-rw-r--r--dev-perl/DBD-mysql/DBD-mysql-4.32.0-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-perl/DBD-mysql/DBD-mysql-4.32.0-r1.ebuild b/dev-perl/DBD-mysql/DBD-mysql-4.32.0-r1.ebuild
new file mode 100644
index 000000000000..133689768ee4
--- /dev/null
+++ b/dev-perl/DBD-mysql/DBD-mysql-4.32.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=CAPTTOFU
+MODULE_VERSION=4.032
+inherit eutils perl-module
+
+DESCRIPTION="The Perl DBD:mysql Module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="embedded test"
+
+RDEPEND="dev-perl/DBI
+ dev-perl/Test-Deep
+ virtual/mysql[embedded?]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-print_embedded_options.patch
+}
+
+src_configure() {
+ if use test; then
+ myconf="${myconf} --testdb=test \
+ --testhost=localhost \
+ --testuser=test \
+ --testpassword=test"
+ fi
+ use embedded && myconf="${myconf} --force-embedded --embedded=mysql_config"
+ perl-module_src_configure
+}
+
+src_test() {
+ einfo
+ einfo "If tests fail, you have to configure your MySQL instance to create"
+ einfo "and grant some privileges to the test user."
+ einfo "You can run the following commands at the MySQL prompt: "
+ einfo "> CREATE USER 'test'@'localhost' IDENTIFIED BY 'test';"
+ einfo "> CREATE DATABASE test;"
+ einfo "> GRANT ALL PRIVILEGES ON test.* TO 'test'@'localhost';"
+ einfo
+ sleep 5
+ perl-module_src_test
+}