summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Class-Singleton
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Class-Singleton')
-rw-r--r--dev-perl/Class-Singleton/Class-Singleton-1.400.0-r1.ebuild15
-rw-r--r--dev-perl/Class-Singleton/Class-Singleton-1.500.0.ebuild21
-rw-r--r--dev-perl/Class-Singleton/Manifest2
-rw-r--r--dev-perl/Class-Singleton/metadata.xml9
4 files changed, 47 insertions, 0 deletions
diff --git a/dev-perl/Class-Singleton/Class-Singleton-1.400.0-r1.ebuild b/dev-perl/Class-Singleton/Class-Singleton-1.400.0-r1.ebuild
new file mode 100644
index 000000000000..b553bee55413
--- /dev/null
+++ b/dev-perl/Class-Singleton/Class-Singleton-1.400.0-r1.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=ABW
+MODULE_VERSION=1.4
+inherit perl-module
+
+DESCRIPTION="Implementation of a Singleton class"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
diff --git a/dev-perl/Class-Singleton/Class-Singleton-1.500.0.ebuild b/dev-perl/Class-Singleton/Class-Singleton-1.500.0.ebuild
new file mode 100644
index 000000000000..e93e3211d4c6
--- /dev/null
+++ b/dev-perl/Class-Singleton/Class-Singleton-1.500.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=SHAY
+MODULE_VERSION=1.5
+inherit perl-module
+
+DESCRIPTION="Implementation of a Singleton class"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+DEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+SRC_TEST=do
diff --git a/dev-perl/Class-Singleton/Manifest b/dev-perl/Class-Singleton/Manifest
new file mode 100644
index 000000000000..acbe498a8be3
--- /dev/null
+++ b/dev-perl/Class-Singleton/Manifest
@@ -0,0 +1,2 @@
+DIST Class-Singleton-1.4.tar.gz 7793 SHA256 cfafc6e7c842e04fc11cc3e700551461a6aaa0b139470273aea2f29026e79150 SHA512 1e7cbc992840fd454e31d79ea1fa78046f52c6c6c369c005248fc675adb0a28dcc1db6e0ebabf4cc0a9a80d684c164315ec6bd1bb56d451d1f09a829141d2328 WHIRLPOOL 3ea469193b84570842c49a2d533bc53f13d616e61f995a55a488f3a6ef190ed6604cb1c6cf32463870a9a0e8f919c4bb09851ff95fd88d22006ee4df1fb62d71
+DIST Class-Singleton-1.5.tar.gz 7785 SHA256 38220d04f02e3a803193c2575a1644cce0b95ad4b95c19eb932b94e2647ef678 SHA512 f061a8b92d5f65e4fbcd14ef36ff1216f84443f487de34c98f7d08d6d18148f156c0cbd6249e75ac448c17547d1172dbda8b670a8e7573d3581c9c1196eb4804 WHIRLPOOL 428ab728bf821357fabf306a9d6df52144f40f0d041e4d257379497bd38dcdf40434956ae0fa48a324451f7a00982e060732e1347bf5077d0a3adbf9e852a280
diff --git a/dev-perl/Class-Singleton/metadata.xml b/dev-perl/Class-Singleton/metadata.xml
new file mode 100644
index 000000000000..141705752d4d
--- /dev/null
+++ b/dev-perl/Class-Singleton/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Class-Singleton</remote-id>
+ <remote-id type="cpan-module">Class::Singleton</remote-id>
+ </upstream>
+</pkgmetadata>