summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-11-02 16:39:31 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-11-02 16:39:48 +0100
commitf55665ccef5d2e6a481ae6dcd1e346dfdcea86f4 (patch)
treec4e0dc93c6335635a44726e64e2ca99a2c4b3d89 /dev-ml
parentmedia-fonts/iosevka: drop 29.2.1, 31.3.0, 31.4.0, 31.5.0, 31.7.1 (diff)
downloadgentoo-f55665ccef5d2e6a481ae6dcd1e346dfdcea86f4.tar.gz
gentoo-f55665ccef5d2e6a481ae6dcd1e346dfdcea86f4.tar.bz2
gentoo-f55665ccef5d2e6a481ae6dcd1e346dfdcea86f4.zip
dev-ml/camlzip: add 1.13
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camlzip/Manifest1
-rw-r--r--dev-ml/camlzip/camlzip-1.13.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/camlzip/Manifest b/dev-ml/camlzip/Manifest
index e346525e3890..45a82840869d 100644
--- a/dev-ml/camlzip/Manifest
+++ b/dev-ml/camlzip/Manifest
@@ -1,3 +1,4 @@
DIST camlzip-1.10.tar.gz 27335 BLAKE2B bbf24953634278589395dd9fcedf1e3becce8dad1f380393dc3ac59589143e1685dc14085ef566e12fb751c6f1a333dd368795a5083b94a43b71e058e86489f3 SHA512 5c42e0d808230e3820b2e7ef34b544ca51a7bf0a484ce4e1c8b1e4966133196bb3ff7c3ca85b9c50050aca389316eb52f0335f6e2ad60c000594a33171b9a9a9
DIST camlzip-1.11.tar.gz 28483 BLAKE2B b270e2a764547117d87a18f9ccca82891bc0dce182ea84f76b693acb34488ff25d8975154b843787554798bfd34c16dc6a25c431f8674c8c59eb2c195167c12b SHA512 4d69ef900437e66e00cd345497ec70f407f28cd8344ee5f2fad685d3bfe356924597d1854b752f2841b4007f96d6e0307cfae7e13cfb6f74951ae3eba5198a06
DIST camlzip-1.12.tar.gz 30453 BLAKE2B 7706879ab3e9d128428404592cc506c681794233ab2efe4c99fe46fdb10b17197aca82f6dd018afdd898d05fa136d1aaebfc54c0255b3b086fc02338c5b67822 SHA512 467c82a253440caf3d8485c949c4717b77dfdeb38ee474278be8e011ed3cd563fdcf436bc262e2c88fd27b44306f70d48808f0d001b3f62ab4c87010af61f76f
+DIST camlzip-1.13.tar.gz 31570 BLAKE2B 8aee80e75aa8afe9c0c1efbc8e70d962a3b5a6558b0d9fd0153a52adb9d72834680ab7720a3e3bdd8256c985a4a08021efe56209b5b9774cdf15a4f1bcbe08a0 SHA512 dc0fff718b089b89b753fe7d70f100f005b4bb4efcb29afb30bb1ccfd0a7c9a1aa8685c033b0c2c86f0573a7bb0772e499d1149bac159ec8fc11426f71903e51
diff --git a/dev-ml/camlzip/camlzip-1.13.ebuild b/dev-ml/camlzip/camlzip-1.13.ebuild
new file mode 100644
index 000000000000..e68f0345ce9f
--- /dev/null
+++ b/dev-ml/camlzip/camlzip-1.13.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit findlib
+
+DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
+HOMEPAGE="https://github.com/xavierleroy/camlzip"
+SRC_URI="https://github.com/xavierleroy/camlzip/archive/rel$(ver_rs 1- '').tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-rel$(ver_rs 1- '')"
+
+LICENSE="LGPL-2.1"
+SLOT="1/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-4.13:=[ocamlopt?]
+ >=sys-libs/zlib-1.1.3"
+DEPEND="${RDEPEND}"
+
+QA_FLAGS_IGNORED=(
+ "usr/lib.*/ocaml/stublibs/dllcamlzip.so"
+ "usr/lib.*/ocaml/zip/zip.cmxs"
+)
+
+src_compile() {
+ emake allbyt
+
+ if use ocamlopt; then
+ emake allopt
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+
+ emake DESTDIR="${D}" install-findlib
+ dosym zip/libcamlzip.a /usr/$(get_libdir)/ocaml/libcamlzip.a
+
+ dodoc README.md Changes
+}