summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorIvan Lloro <ivan.lloro.boada@gmail.com>2024-08-21 16:37:39 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-08-28 09:36:45 +0300
commiteb8e2ffe81b0b57f36d57fc4130aa32fefa1caec (patch)
tree8c4256a2f66343e83e40bab30821da0b84488809 /dev-ml
parentapp-text/cpdf: Take over as maintainer. (diff)
downloadgentoo-eb8e2ffe81b0b57f36d57fc4130aa32fefa1caec.tar.gz
gentoo-eb8e2ffe81b0b57f36d57fc4130aa32fefa1caec.tar.bz2
gentoo-eb8e2ffe81b0b57f36d57fc4130aa32fefa1caec.zip
dev-ml/camlpdf: add 2.7.1
Signed-off-by: Ivan Lloro <ivan.lloro.boada@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camlpdf/Manifest1
-rw-r--r--dev-ml/camlpdf/camlpdf-2.7.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/camlpdf/Manifest b/dev-ml/camlpdf/Manifest
index fce797256b8e..33040fb870b6 100644
--- a/dev-ml/camlpdf/Manifest
+++ b/dev-ml/camlpdf/Manifest
@@ -1 +1,2 @@
DIST camlpdf-2.3.1.tar.gz 601531 BLAKE2B 9534baf9165e7dc48ae37a3fcaabb236e437845ef4e0a60a1c08874a2b240c9b1e96de5bbd6028a3ca87992221773dea34c31b0fa24e9c143632756954baf132 SHA512 0b8d91b6090221f996aee52f22f153a4b74cb85a127bbd5f84492ede8a0a581971a2349281b3879d6c37f4d5d267da583e7e8871372d97a3d636abc3231cb007
+DIST camlpdf-2.7.1.tar.gz 841886 BLAKE2B 30215949fab2517e00cf520ef4f79a6fbf49173e7e2643ac1a47d0dd945063908de2928f7181d2182ad4fe51945bb3f6a89a54aa236a889ea392cd126ef856c8 SHA512 2480a282a6ce09444ed14a3f41561375ecf7e3c57f7559a48ad9791d9f824e59820bfd39aa36910ff6bdc9b160cef76ab90dbbfe628c836c3f5c5081dfd5e452
diff --git a/dev-ml/camlpdf/camlpdf-2.7.1.ebuild b/dev-ml/camlpdf/camlpdf-2.7.1.ebuild
new file mode 100644
index 000000000000..1aada1b8ee02
--- /dev/null
+++ b/dev-ml/camlpdf/camlpdf-2.7.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit findlib
+
+DESCRIPTION="OCaml library for reading, writing, and modifying PDF files"
+HOMEPAGE="https://github.com/johnwhitington/camlpdf/"
+SRC_URI="https://github.com/johnwhitington/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# technically LGPL-2.1+ with linking exception
+LICENSE="LGPL-2.1-with-linking-exception LGPL-2.1+"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt]"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ # parallel make bugs
+ emake -j1
+}
+
+src_install() {
+ findlib_src_install
+ dodoc Changes README.md
+
+ if use doc ; then
+ dodoc introduction_to_camlpdf.pdf
+ dodoc -r doc/camlpdf/html
+ fi
+
+ use examples && dodoc -r examples
+}