summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-03-08 15:37:09 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-03-08 15:37:09 +0100
commit9bd84e55a93799649f072c8242d0325317c0332d (patch)
treef093a4e3b78861e71d398ddd7abaca213802c691 /dev-ml
parentsci-mathematics/mathlib-tools: add changelog link (diff)
downloadgentoo-9bd84e55a93799649f072c8242d0325317c0332d.tar.gz
gentoo-9bd84e55a93799649f072c8242d0325317c0332d.tar.bz2
gentoo-9bd84e55a93799649f072c8242d0325317c0332d.zip
dev-ml/ounit2: bump to 2.2.6
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ounit2/Manifest1
-rw-r--r--dev-ml/ounit2/ounit2-2.2.6.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-ml/ounit2/Manifest b/dev-ml/ounit2/Manifest
index c555d67220b6..7ed9c591f682 100644
--- a/dev-ml/ounit2/Manifest
+++ b/dev-ml/ounit2/Manifest
@@ -1,2 +1,3 @@
DIST ounit-v2.2.3.tbz 57449 BLAKE2B cf4742c4800ff66551416e243285ae0264f94d1665f795039cd37ad717b09fa3ba5cdfb2380169dfcddea5a27a82373ae892adf11155147a081d734091bf39d8 SHA512 dff04859d263e5f80a1606156d07493d0320a2756d0a7f134c63c53078550c7b056587486922bc66a288413af30c59a7e47157636502c6dd10626cf75587f981
DIST ounit-v2.2.4.tbz 57558 BLAKE2B 5cb1eaa1233102af49155b46a1a95742c3c6c584901536ce755e6f6386d0d645639b98fdbab236fe20c93c3bde2632bbfc31c5a076f61cc6b9a7f408ac032643 SHA512 d69dc501a360c31f7854322b5e2c2abcb1e43890737e1cc00c167ee104d5dee471b6b8d8186f8044b0482c91a8f15210a25d833a1e03ed7baabfba923815962f
+DIST ounit2-2.2.6.tar.gz 69910 BLAKE2B 7833738e94990c7e67d27665e994c9e3c1505dcb45e2faaba58ef7de9eccc8fc19437fa983da058b1fa2c464e74d90a4eec22380ebfa01ae5e5a9616faf6ada3 SHA512 4d808866dc4f9de6493a17910fafb2452398aef45cb29add54ed25e15a10ec7715bdd52d40190f618e77fe351d8bb67fbe12c1df6a6736c501792a57f6b3768a
diff --git a/dev-ml/ounit2/ounit2-2.2.6.ebuild b/dev-ml/ounit2/ounit2-2.2.6.ebuild
new file mode 100644
index 000000000000..b454e94dc082
--- /dev/null
+++ b/dev-ml/ounit2/ounit2-2.2.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Unit testing framework for OCaml"
+HOMEPAGE="https://github.com/gildor478/ounit"
+SRC_URI="https://github.com/gildor478/ounit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/ounit-${PV}"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/lwt:=
+ dev-ml/stdlib-shims:=
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dune-install ${PN} ${PN}-lwt
+}