summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-04-24 19:01:41 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-04-24 19:39:48 +0200
commitb9869b7ed17d72348b6037d2f33e20d717c23ded (patch)
treef44198e2b4083b83af505471e5001ad821853f7c /dev-ml/utop
parentdev-ml/gen: bump to 1.1 (diff)
downloadgentoo-b9869b7ed17d72348b6037d2f33e20d717c23ded.tar.gz
gentoo-b9869b7ed17d72348b6037d2f33e20d717c23ded.tar.bz2
gentoo-b9869b7ed17d72348b6037d2f33e20d717c23ded.zip
dev-ml/utop: bump to 2.12.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml/utop')
-rw-r--r--dev-ml/utop/Manifest1
-rw-r--r--dev-ml/utop/utop-2.12.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-ml/utop/Manifest b/dev-ml/utop/Manifest
index 53a099e600f4..3d82bcbb5513 100644
--- a/dev-ml/utop/Manifest
+++ b/dev-ml/utop/Manifest
@@ -1,4 +1,5 @@
DIST utop-2.11.0.tar.gz 416351 BLAKE2B 14d407bd79f83b9b0307ec34ec9330e625e0e5fbc4b4091f98a45d90ff6225c292b6d764746273a5b7e7abda74c83852056f470d8f2f3b16fffc16569ecc6f98 SHA512 ebc27219b0345ab1478499221756806874c430f81aa9f40e7d482d0fd948750919d631b6159faec19fef0d23d14e6a115e6b21a5aa724ce1534e000e5d35bdae
+DIST utop-2.12.1.tar.gz 416596 BLAKE2B a8a31c91fd4f989e3d89bc736caa7b611ba0ccc2de905adcd1cf59fff87770d5a00c2d7a43462940269ae8be2f5980fa5b8d2ec7ba547b937cc1e6a579621f2f SHA512 cc52bdb2a58141e6f7b678c93f69b0aa5ca4c628cb6841e02e6a783191a917bd838c06682d55f4f455a01a7004e43b5193d8574968b8400050b0f7b5a102ca3a
DIST utop-2.9.0.tar.gz 414953 BLAKE2B 96fbf38d4a638137b73264bc523b8a81e47ddd609a7987073313f4b1d628e4e84c31f98195105911dd0930b8d27007cf5cc1633771bc6d2e975bd169e1e3ba9c SHA512 dd3f52fb915493cb32b5ee722361e884a481d04ef175d5bdf58f4032b70826c38b2f5279b7c64b78961170a86bc80fbd59f03026fac99bb5da2b46a8f341aa45
DIST utop-2.9.1.tar.gz 421430 BLAKE2B c90a7fe54c5fbf15ce209e9bf850031e0368104c1f8f61a2d982b2b43d87b4bb95c91e3af6da16ae27ebfab71f2b9907e7dec68d34f619597fe8db45ff363bf4 SHA512 10942a4c7d2e13081f2e02c29b767863176fe90ca5baf48d3be47bb0871a12840d873e5d3eb7d7dd9b0362e849f70afb913ff50c07e66c6b7f221c8bb98fa469
DIST utop-2.9.2.tar.gz 421512 BLAKE2B 235b4739e644877e4b9eef432a00ba053f42f2b4d4fdd9b0bd925af736d9a351c8f9373031bc4fc23835872034d48a27b8eac99d286f57cb975d2b1368f420c8 SHA512 14dd690b459cfea90c565b397b5d914add7e92b152b476ab58576dc827fa204b3d721955bfc3508bcb953778a8d6fb3b299b0293f8ddf64b3f0155fc9a0e7fda
diff --git a/dev-ml/utop/utop-2.12.1.ebuild b/dev-ml/utop/utop-2.12.1.ebuild
new file mode 100644
index 000000000000..0acedbdf1fad
--- /dev/null
+++ b/dev-ml/utop/utop-2.12.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune elisp-common
+
+DESCRIPTION="Universal toplevel for OCaml"
+HOMEPAGE="https://github.com/ocaml-community/utop"
+SRC_URI="https://github.com/ocaml-community/utop/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs +ocamlopt"
+
+ELISP_DEPEND="
+ emacs? (
+ >=app-editors/emacs-24:*
+ >=app-emacs/tuareg-mode-2.2.0
+ )
+"
+DEPEND="
+ dev-ml/lambda-term:=
+ dev-ml/logs:=
+ dev-ml/lwt:=
+ dev-ml/react:=
+ dev-ml/zed:=
+"
+RDEPEND="
+ ${DEPEND}
+ ${ELISP_DEPEND}
+"
+BDEPEND="
+ dev-ml/cppo
+ dev-ml/findlib
+ ${ELISP_DEPEND}
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ dune_src_compile
+
+ use emacs &&
+ BYTECOMPFLAGS="-L src/top" elisp-compile src/top/*.el
+}
+
+src_install() {
+ dune_src_install
+
+ if use emacs ; then
+ elisp-install ${PN} src/top/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}