summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-12-05 03:36:48 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-12-05 04:22:29 +0100
commit6d6e05018185c1a71576b41743cbb7378cedeb68 (patch)
tree599801c52966928f7d95170864a617bad16508c4 /dev-ml/ocaml-process
parentdev-ml/ocaml-stdint: new package; add version 0.7.0 (diff)
downloadgentoo-6d6e05018185c1a71576b41743cbb7378cedeb68.tar.gz
gentoo-6d6e05018185c1a71576b41743cbb7378cedeb68.tar.bz2
gentoo-6d6e05018185c1a71576b41743cbb7378cedeb68.zip
dev-ml/ocaml-process: new package; add version 0.2.1
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml/ocaml-process')
-rw-r--r--dev-ml/ocaml-process/Manifest1
-rw-r--r--dev-ml/ocaml-process/metadata.xml13
-rw-r--r--dev-ml/ocaml-process/ocaml-process-0.2.1.ebuild29
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/ocaml-process/Manifest b/dev-ml/ocaml-process/Manifest
new file mode 100644
index 000000000000..03a2a410140d
--- /dev/null
+++ b/dev-ml/ocaml-process/Manifest
@@ -0,0 +1 @@
+DIST ocaml-process-0.2.1.tar.gz 5904 BLAKE2B 90a03e53e79adae559bbdcf4717db53d5e79cf22a22e7d6daad4c123a8b275f7b984ed40b7132653c31bb9b1d7c39c1918e0455597f70103ddb18b89ecf00d9a SHA512 0ca352a273797218e1785e1f6ed024448461cefeb54f143574230c844747a81355b97dd19fe9ddfe31d1a69c03dccf895fadc086f61a3d7a9f5397538432db92
diff --git a/dev-ml/ocaml-process/metadata.xml b/dev-ml/ocaml-process/metadata.xml
new file mode 100644
index 000000000000..0f616a0514e6
--- /dev/null
+++ b/dev-ml/ocaml-process/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/dsheets/ocaml-process/issues/</bugs-to>
+ <remote-id type="github">dsheets/ocaml-process</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-process/ocaml-process-0.2.1.ebuild b/dev-ml/ocaml-process/ocaml-process-0.2.1.ebuild
new file mode 100644
index 000000000000..66969b86741b
--- /dev/null
+++ b/dev-ml/ocaml-process/ocaml-process-0.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="Easy process control for OCaml"
+HOMEPAGE="https://github.com/dsheets/ocaml-process"
+SRC_URI="https://github.com/dsheets/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-ml/ocamlbuild
+ test? ( dev-ml/alcotest )
+"
+
+src_install() {
+ findlib_src_install
+}
+
+src_test() {
+ emake -j1 test
+}