summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-06-28 22:59:17 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-06-28 23:03:25 +0200
commit654e9db4b6bacedfcc526446fb4c2fdc8a962a3b (patch)
tree86d132bd2d9cba6e9ed81bbc955633cdea066875 /dev-ml/num
parentsys-apps/openrc: drop 0.54.1 (diff)
downloadgentoo-654e9db4b6bacedfcc526446fb4c2fdc8a962a3b.tar.gz
gentoo-654e9db4b6bacedfcc526446fb4c2fdc8a962a3b.tar.bz2
gentoo-654e9db4b6bacedfcc526446fb4c2fdc8a962a3b.zip
dev-ml/num: add 1.5
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/num')
-rw-r--r--dev-ml/num/Manifest1
-rw-r--r--dev-ml/num/num-1.5.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-ml/num/Manifest b/dev-ml/num/Manifest
index c545fca9b107..138635061223 100644
--- a/dev-ml/num/Manifest
+++ b/dev-ml/num/Manifest
@@ -1,2 +1,3 @@
DIST num-1.3.tar.gz 66251 BLAKE2B d6fde246693c8aef3b881a4ebc2b601392e0f0bf561dc4f4d32a5e1f835a5186deba3ffa77c88c6c05cd6e837dc836567fcabffefae99ce1ccae94e1bdfc849a SHA512 c88310f8c45700990095e6b2e9abf24c27347711b9abfd1dde75e540fbbfc6a365e6713bd69f66009af305728fcb36dc61eb37fdd0be7d73824b0e92fbe8c031
DIST num-1.4.tar.gz 66327 BLAKE2B 59eae642e19f452dd911ef6c32b89978f2034a5fcaece4a358f3da447c8d6cb2b2581c39d032eb117edaf7ecf942583281eb6e31716b06960e768c2a985e099e SHA512 0cc9be8ad95704bb683b4bf6698bada1ee9a40dc05924b72adc7b969685c33eeb68ccf174cc09f6a228c48c18fe94af06f28bebc086a24973a066da620db8e6f
+DIST num-1.5.tar.gz 67633 BLAKE2B 848dc8174bcdc5756ab036f9ec9cc9f6727d7d8e1079bd1c37611c7cc73939ce5cead4ba6acf4b6a1789640e824afc78faa43e24825e1f4cca37e3a76946e4f1 SHA512 110dd01140c1c96f5f067aa824bb63f74a26411dcaa65aaf04cb6c44b116ca02aaab9505f431c66964388ce4a31d86da5928b4c0e5557800e834de80bed46495
diff --git a/dev-ml/num/num-1.5.ebuild b/dev-ml/num/num-1.5.ebuild
new file mode 100644
index 000000000000..5b8ad18e290c
--- /dev/null
+++ b/dev-ml/num/num-1.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Not using dune for now, bug #775119
+inherit findlib
+
+DESCRIPTION="Library for arbitrary-precision integer and rational arithmetic"
+HOMEPAGE="https://github.com/ocaml/num"
+SRC_URI="https://github.com/ocaml/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="+ocamlopt"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
+BDEPEND="${RDEPEND}"
+DEPEND="dev-ml/findlib:=[ocamlopt?]"
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" \
+ NATDYNLINK="$(usex ocamlopt true false)" \
+ NATIVE_COMPILER="$(usex ocamlopt true false)"
+}
+
+src_test() {
+ # Override needed to not use dune
+ emake test
+}
+
+src_install() {
+ # OCaml generates textrels on 32-bit arches
+ if use arm || use ppc || use x86 ; then
+ export QA_TEXTRELS='.*'
+ fi
+ findlib_src_install \
+ NATDYNLINK="$(usex ocamlopt true false)" \
+ NATIVE_COMPILER="$(usex ocamlopt true false)"
+
+ if has_version ">=dev-ml/findlib-1.9" ; then
+ # See bug #803275
+ rm "${ED}/usr/$(get_libdir)/ocaml/num-top/META" || die
+ fi
+}