summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/lwt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/lwt')
-rw-r--r--dev-ml/lwt/Manifest3
-rw-r--r--dev-ml/lwt/files/lwt-2.4.3-ocaml-4.01.patch36
-rw-r--r--dev-ml/lwt/lwt-2.4.3.ebuild38
-rw-r--r--dev-ml/lwt/lwt-2.4.6.ebuild43
-rw-r--r--dev-ml/lwt/lwt-2.5.0.ebuild41
-rw-r--r--dev-ml/lwt/metadata.xml22
6 files changed, 183 insertions, 0 deletions
diff --git a/dev-ml/lwt/Manifest b/dev-ml/lwt/Manifest
new file mode 100644
index 000000000000..bfec53c0e4b0
--- /dev/null
+++ b/dev-ml/lwt/Manifest
@@ -0,0 +1,3 @@
+DIST lwt-2.4.3.tar.gz 504000 SHA256 efee23937750290d6dee96eed6c0bbdb19817d5be6eefcba61ac5031fac10107 SHA512 725d50a096a43294d49ae2322fdc985c301ce6a8ff5c956925225d7977e787ccb446e36a9db5fdbb50f284b9f1a3a12a52d1aa44d4400feecb59f6f938ed00ad WHIRLPOOL c5999e950008902600b43bf39f174ed0bc2cb3f6dce983d885416969a3bb98170ec8b74c8f5829459c3c96d160e5b4c8491b7057e7efeac035a46c9846ff7764
+DIST lwt-2.4.6.tar.gz 306510 SHA256 9f90c6b326e603865bae9a882301e35ee745d22e6b886b488a26dfa94ca69ff1 SHA512 8ba7cf74a228016f662523a14c083367e1d5eae43dbc208b8620fa867b44b99ea35644a9788fba3e3031e94fd0a852bdf5e85d250494fdbf6ddbe7959cb858e4 WHIRLPOOL d5fea0daf60e9adb213652d2cb4857bae81342c9b1e1e6492137e9683ffe3ac360e63623cfa8771b9406d2a2a8ec110681f8991399ee31028e9efd2b6f0a43eb
+DIST lwt-2.5.0.tar.gz 1278567 SHA256 37ae28a56bc5e112947ff84562b37fbd2263d54ecbb0b1e2076b2b775f546130 SHA512 a951f55ebd8440f15c1d60ab41cefe9afea12332f64e477f50537de231535814d704baea0ed167bee2f7e2c7ec8c128811d3d446cad2d6b8d46ab612a160ed40 WHIRLPOOL 661db9f59a8205c649309c95292aca80a7e9195f2ac8c4cb0dfca56689e7bae881eb1b4869f02d27a09d33b0aca5bf83f937a8e4389adefb3b9fab071779392d
diff --git a/dev-ml/lwt/files/lwt-2.4.3-ocaml-4.01.patch b/dev-ml/lwt/files/lwt-2.4.3-ocaml-4.01.patch
new file mode 100644
index 000000000000..eb2566705da1
--- /dev/null
+++ b/dev-ml/lwt/files/lwt-2.4.3-ocaml-4.01.patch
@@ -0,0 +1,36 @@
+commit 0df80f6d05625f80e1e3e05a46e355728881b38a
+Author: Anil Madhavapeddy <anil@recoil.org>
+Date: Sat Aug 3 20:20:55 2013 +0100
+
+ OCaml 4.01.0dev has a Unix.O_CLOEXEC flag, so add this to Lwt_unix too.
+
+ This was added quite recently in ocaml/ocaml@2207c45056e69d1ea5
+
+diff --git a/src/unix/lwt_unix.ml b/src/unix/lwt_unix.ml
+index 5115ffe..4222f7b 100644
+--- a/src/unix/lwt_unix.ml
++++ b/src/unix/lwt_unix.ml
+@@ -596,6 +596,9 @@ type open_flag =
+ #if ocaml_version >= (3, 13)
+ | O_SHARE_DELETE
+ #endif
++#if ocaml_version >= (4, 01)
++ | O_CLOEXEC
++#endif
+
+ #if windows
+
+diff --git a/src/unix/lwt_unix.mli b/src/unix/lwt_unix.mli
+index cc9df59..f85df52 100644
+--- a/src/unix/lwt_unix.mli
++++ b/src/unix/lwt_unix.mli
+@@ -315,6 +315,9 @@ type open_flag =
+ #if ocaml_version >= (3, 13)
+ | O_SHARE_DELETE
+ #endif
++#if ocaml_version >= (4, 01)
++ | O_CLOEXEC
++#endif
+
+ val openfile : string -> open_flag list -> file_perm -> file_descr Lwt.t
+ (** Wrapper for [Unix.openfile]. *)
diff --git a/dev-ml/lwt/lwt-2.4.3.ebuild b/dev-ml/lwt/lwt-2.4.3.ebuild
new file mode 100644
index 000000000000..f082161e83e7
--- /dev/null
+++ b/dev-ml/lwt/lwt-2.4.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Cooperative light-weight thread library for OCaml"
+SRC_URI="http://ocsigen.org/download/${P}.tar.gz"
+HOMEPAGE="http://ocsigen.org/lwt"
+
+IUSE="gtk +react +ssl"
+
+DEPEND="react? ( dev-ml/react:= )
+ dev-libs/libev
+ ssl? ( >=dev-ml/ocaml-ssl-0.4.0:= )
+ gtk? ( dev-ml/lablgtk:= dev-libs/glib:2 )"
+
+RDEPEND="${DEPEND}
+ !<www-servers/ocsigen-1.1"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2.1-with-linking-exception"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+
+DOCS=( "CHANGES" "CHANGES.darcs" "README" )
+PATCHES=( "${FILESDIR}/${P}-ocaml-4.01.patch" )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable gtk glib)
+ $(use_enable react)
+ $(use_enable ssl)" \
+ oasis_src_configure
+}
diff --git a/dev-ml/lwt/lwt-2.4.6.ebuild b/dev-ml/lwt/lwt-2.4.6.ebuild
new file mode 100644
index 000000000000..e9327413e8ac
--- /dev/null
+++ b/dev-ml/lwt/lwt-2.4.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+# fails to build
+#OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Cooperative light-weight thread library for OCaml"
+SRC_URI="https://github.com/ocsigen/lwt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="http://ocsigen.org/lwt"
+
+IUSE="gtk +react +ssl text toplevel"
+
+DEPEND="react? ( >=dev-ml/react-1.2:= )
+ dev-libs/libev
+ ssl? ( >=dev-ml/ocaml-ssl-0.4.0:= )
+ gtk? ( dev-ml/lablgtk:= dev-libs/glib:2 )
+ text? ( >=dev-ml/ocaml-text-0.4:= )
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
+
+RDEPEND="${DEPEND}
+ !<www-servers/ocsigen-1.1"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2.1-with-linking-exception"
+KEYWORDS="~amd64 ~x86-fbsd"
+
+DOCS=( "CHANGES" "README" )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable gtk glib)
+ $(use_enable react)
+ $(use_enable ssl)
+ $(use_enable toplevel)
+ $(use_enable text)
+ --disable-ppx" \
+ oasis_src_configure
+}
diff --git a/dev-ml/lwt/lwt-2.5.0.ebuild b/dev-ml/lwt/lwt-2.5.0.ebuild
new file mode 100644
index 000000000000..ac81e538d517
--- /dev/null
+++ b/dev-ml/lwt/lwt-2.5.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+# fails to build
+#OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Cooperative light-weight thread library for OCaml"
+SRC_URI="https://github.com/ocsigen/lwt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="http://ocsigen.org/lwt"
+
+IUSE="gtk +react +ssl"
+
+DEPEND="react? ( >=dev-ml/react-1.2:= )
+ dev-libs/libev
+ ssl? ( >=dev-ml/ocaml-ssl-0.4.0:= )
+ gtk? ( dev-ml/lablgtk:= dev-libs/glib:2 )
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
+
+RDEPEND="${DEPEND}
+ !<www-servers/ocsigen-1.1"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2.1-with-linking-exception"
+KEYWORDS="~amd64 ~x86-fbsd"
+
+DOCS=( "CHANGES" "README.md" )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable gtk glib)
+ $(use_enable react)
+ $(use_enable ssl)
+ --enable-camlp4
+ --disable-ppx" \
+ oasis_src_configure
+}
diff --git a/dev-ml/lwt/metadata.xml b/dev-ml/lwt/metadata.xml
new file mode 100644
index 000000000000..907abc8009ab
--- /dev/null
+++ b/dev-ml/lwt/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ </maintainer>
+ <maintainer>
+ <email>pclairam@gmail.com</email>
+ <name>Pierre Clairambault</name>
+ </maintainer>
+ <use>
+ <flag name="react">Enables support for <pkg>dev-ml/react</pkg>: Functional reactive programming (signals, events, etc.).</flag>
+ <flag name="toplevel">Enables enhanced toplevel.</flag>
+ <flag name="text">Enables text mode utilities.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">ocsigen/lwt</remote-id>
+ </upstream>
+</pkgmetadata>