summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-06-22 21:42:11 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-06-22 22:00:10 +0200
commit13854efe25ee83d52c6a79b95d5ec621350b9978 (patch)
tree0f3a7631101ec6257b0f43a25fdb79942d8d8265 /dev-lua
parentdev-lua/luarocks: drop 3.11.0 (diff)
downloadgentoo-13854efe25ee83d52c6a79b95d5ec621350b9978.tar.gz
gentoo-13854efe25ee83d52c6a79b95d5ec621350b9978.tar.bz2
gentoo-13854efe25ee83d52c6a79b95d5ec621350b9978.zip
dev-lua/luasec: drop 1.2.0, 1.3.1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luasec/Manifest2
-rw-r--r--dev-lua/luasec/luasec-1.2.0.ebuild89
-rw-r--r--dev-lua/luasec/luasec-1.3.1.ebuild89
3 files changed, 0 insertions, 180 deletions
diff --git a/dev-lua/luasec/Manifest b/dev-lua/luasec/Manifest
index 9f53f19a70ee..beb004f213cc 100644
--- a/dev-lua/luasec/Manifest
+++ b/dev-lua/luasec/Manifest
@@ -1,3 +1 @@
-DIST luasec-1.2.0.tar.gz 53379 BLAKE2B dad93b341565b602fa02a5551a127bce42e76cee5abb0314f9cc4a98f162d23b0f8b4b9c0f16423095e4b54ec5ab260ee06bef5993ad46f559ad1295dcc28856 SHA512 5564f73495bef7c5683285ff7648c7b82a3a3dfdce96e88c77cc8835427b6595a694e5a2bf0a4f6332fe52b8aed3d94531607df81260d7597458a6fb0465d3fe
-DIST luasec-1.3.1.tar.gz 54807 BLAKE2B e09d340b8bc391830d671dd5cbec76bd5190bebdd2e534800bea8efd19749a4379e2681bb7a6e6551da49109345f0b846904c222c0ecada6135d775e2060bfc7 SHA512 cfa4187518445abc6591bd0c24924122b62252be25ffd5564cf291f9a2ae3702a5fa299ffd265d2e0e8315b90d6783eccace4ff560f54f299161d3c5e3749508
DIST luasec-1.3.2.tar.gz 54925 BLAKE2B d86a241c22083dc0ed201d83392e694fbefed207feafd758d7ba1235ea209b4dc66301abca4bd113f7074c88d5193fd9a28cbcbba4bed2f96fa669d799e1a38f SHA512 8f0c4b5ff87c024685b23770e1d342467554b8dc19a1704076e184d9e84b966f171091c31d1da135ab009e850275adc2bf2720fc9f32c83ac23f0a42f13d311f
diff --git a/dev-lua/luasec/luasec-1.2.0.ebuild b/dev-lua/luasec/luasec-1.2.0.ebuild
deleted file mode 100644
index b96cb6076757..000000000000
--- a/dev-lua/luasec/luasec-1.2.0.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-
-inherit lua toolchain-funcs
-
-DESCRIPTION="Lua binding for OpenSSL library to provide TLS/SSL communication"
-HOMEPAGE="https://github.com/brunoos/luasec"
-SRC_URI="https://github.com/brunoos/luasec/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~sparc x86"
-
-RDEPEND="
- >=dev-lua/luasocket-3.0_rc1_p20200328-r103[${LUA_USEDEP}]
- dev-libs/openssl:0=
- ${LUA_DEPS}
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-lua_src_prepare() {
- pushd "${BUILD_DIR}" || die
-
- ${ELUA} src/options.lua -g /usr/include/openssl/ssl.h > src/options.c || die
-
- popd
-}
-
-src_prepare() {
- default
-
- # Respect users CFLAGS
- sed -e 's/-O2//g' -i src/Makefile || die
-
- # Allow to redefine libraries linking
- sed -e 's/LIBS=/LIBS?=/g' -i src/Makefile || die
-
- lua_copy_sources
-
- lua_foreach_impl lua_src_prepare
-}
-
-lua_src_compile() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "CC=$(tc-getCC)"
- "CCLD=$(tc-getCC)"
- "INC_PATH=-I$(lua_get_include_dir)"
- "LIB_PATH=-L$(lua_get_cmod_dir)/socket"
- "LIBS=$($(tc-getPKG_CONFIG) --libs openssl) $(lua_get_cmod_dir)/socket/core.so"
- "MYLDFLAGS=-Wl,-rpath,$(lua_get_cmod_dir)/socket -Wl,-soname=socket/core.so"
- "EXTRA="
- "DEFS="
- )
-
- emake "${myemakeargs[@]}" linux
-
- popd
-}
-
-src_compile() {
- lua_foreach_impl lua_src_compile
-}
-
-lua_src_install() {
- pushd "${BUILD_DIR}" || die
-
- local emakeargs=(
- "DESTDIR=${ED}"
- "LUAPATH=$(lua_get_lmod_dir)"
- "LUACPATH=$(lua_get_cmod_dir)"
- )
-
- emake "${emakeargs[@]}" install
-
- popd
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-
- einstalldocs
-}
diff --git a/dev-lua/luasec/luasec-1.3.1.ebuild b/dev-lua/luasec/luasec-1.3.1.ebuild
deleted file mode 100644
index 8371ae1e3422..000000000000
--- a/dev-lua/luasec/luasec-1.3.1.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-
-inherit lua toolchain-funcs
-
-DESCRIPTION="Lua binding for OpenSSL library to provide TLS/SSL communication"
-HOMEPAGE="https://github.com/brunoos/luasec"
-SRC_URI="https://github.com/brunoos/luasec/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~sparc x86"
-
-RDEPEND="
- >=dev-lua/luasocket-3.0_rc1_p20200328-r103[${LUA_USEDEP}]
- dev-libs/openssl:0=
- ${LUA_DEPS}
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-lua_src_prepare() {
- pushd "${BUILD_DIR}" || die
-
- ${ELUA} src/options.lua -g /usr/include/openssl/ssl.h > src/options.c || die
-
- popd
-}
-
-src_prepare() {
- default
-
- # Respect users CFLAGS
- sed -e 's/-O2//g' -i src/Makefile || die
-
- # Allow to redefine libraries linking
- sed -e 's/LIBS=/LIBS?=/g' -i src/Makefile || die
-
- lua_copy_sources
-
- lua_foreach_impl lua_src_prepare
-}
-
-lua_src_compile() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "CC=$(tc-getCC)"
- "CCLD=$(tc-getCC)"
- "INC_PATH=-I$(lua_get_include_dir)"
- "LIB_PATH=-L$(lua_get_cmod_dir)/socket"
- "LIBS=$($(tc-getPKG_CONFIG) --libs openssl) $(lua_get_cmod_dir)/socket/core.so"
- "MYLDFLAGS=-Wl,-rpath,$(lua_get_cmod_dir)/socket -Wl,-soname=socket/core.so"
- "EXTRA="
- "DEFS="
- )
-
- emake "${myemakeargs[@]}" linux
-
- popd
-}
-
-src_compile() {
- lua_foreach_impl lua_src_compile
-}
-
-lua_src_install() {
- pushd "${BUILD_DIR}" || die
-
- local emakeargs=(
- "DESTDIR=${ED}"
- "LUAPATH=$(lua_get_lmod_dir)"
- "LUACPATH=$(lua_get_cmod_dir)"
- )
-
- emake "${emakeargs[@]}" install
-
- popd
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-
- einstalldocs
-}