summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-lua/luajson
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-lua/luajson')
-rw-r--r--dev-lua/luajson/Manifest2
-rw-r--r--dev-lua/luajson/luajson-1.3.2.ebuild29
-rw-r--r--dev-lua/luajson/luajson-1.3.3.ebuild29
-rw-r--r--dev-lua/luajson/metadata.xml11
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-lua/luajson/Manifest b/dev-lua/luajson/Manifest
new file mode 100644
index 000000000000..fab15cccdc30
--- /dev/null
+++ b/dev-lua/luajson/Manifest
@@ -0,0 +1,2 @@
+DIST luajson-1.3.2.tar.gz 42139 SHA256 744f27548bfe6b63ab083008182666b76ce651b5e600d27ed3343ad3da4b1032 SHA512 502fc5b221128b1af291619ffaebdfc8bb4ee6bbfd041b6e18974aee09c3e73fe0aaaf650bbded818f690c332cb1f74de3e28f11ac2b5f18b751bc6259a07633 WHIRLPOOL b582631cdecadd16dd637f36499f526f609584b9295df9d05d19b027e4ac4ac8dd4c9d8fc75b042266c1726518c5cd2028ba32475c59b855ecfccb7949096287
+DIST luajson-1.3.3.tar.gz 42653 SHA256 6a986efa210a912a04c8e6cae8f3b5e72172c02f974152e14818af6598a5e2db SHA512 9b507148afaf59871f97e7cf78ad35dc01497d553699d1d1a928543fad6a375aebc3852da86d51d744f10ab2ec24c7b1d7c380852da8134ae05f2f22f6f200c2 WHIRLPOOL 2e24926f6c294bf2f907010d3bfbf03f1248df70c5d6b4d6ee37ed6ef755a3daccc98122e2dd9537ed0041e2d7f2be7c2b15acee5e2afc6e599fa7cc49190ed6
diff --git a/dev-lua/luajson/luajson-1.3.2.ebuild b/dev-lua/luajson/luajson-1.3.2.ebuild
new file mode 100644
index 000000000000..3505af8d2f00
--- /dev/null
+++ b/dev-lua/luajson/luajson-1.3.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="JSON Parser/Constructor for Lua"
+HOMEPAGE="http://www.eharning.us/wiki/luajson/"
+SRC_URI="https://github.com/harningt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa ~mips x86"
+IUSE="test"
+
+RDEPEND="|| ( >=dev-lang/lua-5.1 dev-lang/luajit:2 )
+ dev-lua/lpeg"
+DEPEND="test? ( dev-lua/luafilesystem )"
+
+# lunit not in the tree yet
+RESTRICT="test"
+
+# nothing to compile
+src_compile() { :; }
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+ dodoc README docs/ReleaseNotes-${PV}.txt docs/LuaJSON.txt
+}
diff --git a/dev-lua/luajson/luajson-1.3.3.ebuild b/dev-lua/luajson/luajson-1.3.3.ebuild
new file mode 100644
index 000000000000..3009f74acd7a
--- /dev/null
+++ b/dev-lua/luajson/luajson-1.3.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="JSON Parser/Constructor for Lua"
+HOMEPAGE="http://www.eharning.us/wiki/luajson/"
+SRC_URI="https://github.com/harningt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ppc ppc64 sparc ~x86"
+IUSE="test"
+
+RDEPEND="|| ( >=dev-lang/lua-5.1 dev-lang/luajit:2 )
+ dev-lua/lpeg"
+DEPEND="test? ( dev-lua/luafilesystem )"
+
+# lunit not in the tree yet
+RESTRICT="test"
+
+# nothing to compile
+src_compile() { :; }
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+ dodoc README docs/ReleaseNotes-${PV}.txt docs/LuaJSON.txt
+}
diff --git a/dev-lua/luajson/metadata.xml b/dev-lua/luajson/metadata.xml
new file mode 100644
index 000000000000..77cd520a2d3d
--- /dev/null
+++ b/dev-lua/luajson/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">harningt/luajson</remote-id>
+ </upstream>
+</pkgmetadata>