summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:13:01 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:31 +0100
commit05ed6c39e4b6c0e8b71eed9968a06c6837580e4e (patch)
tree5442767f011fb64bd22b28f157ecc75e5f01998c /dev-lua/busted
parentdev-lua/busted: update EAPI 7 -> 8 (diff)
downloadgentoo-05ed6c39e4b6c0e8b71eed9968a06c6837580e4e.tar.gz
gentoo-05ed6c39e4b6c0e8b71eed9968a06c6837580e4e.tar.bz2
gentoo-05ed6c39e4b6c0e8b71eed9968a06c6837580e4e.zip
dev-lua/busted: drop 2.0.0-r101
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/busted')
-rw-r--r--dev-lua/busted/busted-2.0.0-r101.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-lua/busted/busted-2.0.0-r101.ebuild b/dev-lua/busted/busted-2.0.0-r101.ebuild
deleted file mode 100644
index 127e8b9b3857..000000000000
--- a/dev-lua/busted/busted-2.0.0-r101.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-
-inherit lua toolchain-funcs
-
-DESCRIPTION="Elegant Lua unit testing"
-HOMEPAGE="http://olivinelabs.com/busted/"
-SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86"
-IUSE="test"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-lua/lua_cliargs[${LUA_USEDEP}]
- dev-lua/luafilesystem[${LUA_USEDEP}]
- dev-lua/luasystem[${LUA_USEDEP}]
- dev-lua/dkjson[${LUA_USEDEP}]
- dev-lua/say[${LUA_USEDEP}]
- dev-lua/luassert[${LUA_USEDEP}]
- dev-lua/lua-term[${LUA_USEDEP}]
- dev-lua/penlight[${LUA_USEDEP}]
- dev-lua/mediator_lua[${LUA_USEDEP}]
- ${LUA_DEPS}
-"
-
-DEPEND="${RDEPEND}"
-
-BDEPEND="
- virtual/pkgconfig
- test? (
- dev-lua/busted
- ${RDEPEND}
- )
-"
-
-lua_src_test() {
- busted --lua=${ELUA} || die
-}
-
-src_test() {
- lua_foreach_impl lua_src_test
-}
-
-lua_src_install() {
- insinto $(lua_get_lmod_dir)
- doins -r busted
-}
-
-src_install() {
- dobin bin/busted
-
- lua_foreach_impl lua_src_install
-
- einstalldocs
-}