summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2024-11-01 08:16:38 +0800
committerYixun Lan <dlan@gentoo.org>2024-11-01 08:48:33 +0800
commitcae617e8e011b17d112755d9069e7e2aa300ab13 (patch)
treece86634c96f6b3f7765a77b302acfa2772b133ac /dev-libs
parentdev-build/cmake-fedora: fix sandbox issue (diff)
downloadgentoo-cae617e8e011b17d112755d9069e7e2aa300ab13.tar.gz
gentoo-cae617e8e011b17d112755d9069e7e2aa300ab13.tar.bz2
gentoo-cae617e8e011b17d112755d9069e7e2aa300ab13.zip
dev-libs/libgpiod: add 2.2
disable dbus & bindings-lib for now which require glibc-2.80 which masked Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libgpiod/Manifest1
-rw-r--r--dev-libs/libgpiod/libgpiod-2.2.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-libs/libgpiod/Manifest b/dev-libs/libgpiod/Manifest
index 10391428f06e..45084384dc5d 100644
--- a/dev-libs/libgpiod/Manifest
+++ b/dev-libs/libgpiod/Manifest
@@ -1,3 +1,4 @@
DIST libgpiod-1.6.4.tar.xz 334552 BLAKE2B 3bf52dab263638967e0f59c858e22f3d8ec1c9565ba1edd665dff580a883fbc6aa49a944e6df4da8fca9c2df873e222ed4e055c9792ee27d4562b3c2d0c65b79 SHA512 23ea27147039ae34505263dbfbb3ca9985fc671d26e489ccaf150543d4e853f709393f46a8a5a1e682fa91378163bd2db6c689159ef73c3a8d1eeea422eacda0
DIST libgpiod-2.1.2.tar.xz 419964 BLAKE2B 62b1df3af28d0ab4988101f6bcbce750fd5bd7db874a34c196630bc8badaefc8e3c5c60bbf3c4dfff074d4d2f681d3339fc32c9eeecf395b595b91e5727572e5 SHA512 e921ac34692d5ae92a29592e2103229a8b0afcdcfa750e30fbd292554cd2e59fd51aefc8fa2ad1c9ad5ea4a93bb3443e8f6e8f4f1537109b263aba33317106f3
DIST libgpiod-2.1.3.tar.xz 420048 BLAKE2B a012720dc3569fa80f990303a9fdc2552bf9661ff98871c9062e76d46db0b1f8d819c2941d8325baea377d12b562aeec25e1d5c814183646f09ef93e67052c4f SHA512 a617a25b9b3b59edb45a6bcc59321c369f5d7f09d33edcf0be5ea39fbc0396f6c1e29b32eac1cefba85de5c92c9b7c198f4598b6a666970c8df11e7ce4358ff4
+DIST libgpiod-2.2.tar.xz 499012 BLAKE2B 4d86027698eff325c677163e3be85e95fbb1bd44f5256afa940858675ec13ce3c4bf409b21144c8c2453681a7c7a6e9687a38e51cb970b8d7418ff44de165d12 SHA512 b06965b084e02e808eed3051c33b95874f90161a47ec16655d7b093156a4bf0af0d553c8778bde81eb0bd023c4109989c5893326321b54b61c6a2988d3fc8351
diff --git a/dev-libs/libgpiod/libgpiod-2.2.ebuild b/dev-libs/libgpiod/libgpiod-2.2.ebuild
new file mode 100644
index 000000000000..ad05cd403b56
--- /dev/null
+++ b/dev-libs/libgpiod/libgpiod-2.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info
+
+DESCRIPTION="C library and tools for interacting with the linux GPIO character device"
+HOMEPAGE="https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git/"
+SRC_URI="https://mirrors.edge.kernel.org/pub/software/libs/libgpiod/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+# Reflects the ABI of libgpiod.so
+SLOT="0/3"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+IUSE="+tools cxx python test"
+RESTRICT="!test? ( test )"
+
+# --enable-dbus #glib-2.80 masked
+# --enable-tests enable libgpiod tests [default=no]
+# --enable-bindings-cxx enable C++ bindings [default=no]
+# --enable-bindings-python
+# --enable-bindings-rust
+# --enable-bindings-glib
+DEPEND="
+ test? (
+ >=dev-libs/glib-2.50
+ >=sys-apps/kmod-18
+ >=sys-apps/util-linux-2.33.1
+ >=virtual/libudev-215
+ cxx? ( <dev-cpp/catch-3.5:0 )
+ )
+"
+
+pkg_setup() {
+ CONFIG_CHECK="~GPIO_CDEV_V1"
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable tools)
+ $(use_enable cxx bindings-cxx)
+ $(use_enable test tests)
+ $(use_enable python bindings-python)
+ --enable-examples
+ --disable-dbus
+ --disable-profiling
+ --disable-bindings-rust
+ --disable-bindings-glib
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -type f -delete || die
+ find "${D}" -name "*.a" -delete || die
+}