summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2024-10-04 15:38:54 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-11-02 14:45:59 +0200
commit8f1c4cf7bd905df41c5869c48a2e3427fe5be2f8 (patch)
tree1e2b310d526627d311110095e285006a3a4407f4 /dev-libs
parentsys-cluster/charliecloud: re revbump (diff)
downloadgentoo-8f1c4cf7bd905df41c5869c48a2e3427fe5be2f8.tar.gz
gentoo-8f1c4cf7bd905df41c5869c48a2e3427fe5be2f8.tar.bz2
gentoo-8f1c4cf7bd905df41c5869c48a2e3427fe5be2f8.zip
dev-libs/capstone: add 6.0.0_alpha1
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/capstone/Manifest1
-rw-r--r--dev-libs/capstone/capstone-6.0.0_alpha1.ebuild106
-rw-r--r--dev-libs/capstone/files/capstone-werror.patch (renamed from dev-libs/capstone/files/capstone-9999-werror.patch)0
3 files changed, 107 insertions, 0 deletions
diff --git a/dev-libs/capstone/Manifest b/dev-libs/capstone/Manifest
index 1084fc4eb661..f3e37db537f8 100644
--- a/dev-libs/capstone/Manifest
+++ b/dev-libs/capstone/Manifest
@@ -1,2 +1,3 @@
DIST capstone-5.0.1.tar.gz 7654195 BLAKE2B 83f6681d4c9c748df00daf59f7b33637ab72eee661261c22acae40a6db2def70bb6b5339d731244fdbae6f1e1b0b5b22bb6f60c1390a1bebceb97b3f810aedb0 SHA512 350aba77ce2d96b5c25764913591ba80e4497177ae0a8b2c820c6755ee8310848fbfc54e7ccac27fafc2dbc6778118ad92c53d1b5cb601d4fa146dec7d7e11e5
DIST capstone-5.0.3.tar.gz 7650875 BLAKE2B 3750964a95cbaba685dfb5cf511f12d18f2c157fb622a15c4615734987b8a49ffacf021457f36302606ccf9055e45a7fc56af000b8f09df467922896b431537c SHA512 2fd3194dd37065e6091d208c7670b12c0ca6872931eef794bd6b2dd624601c843e8ee6c5714eae0372e394e91a9bc1e4de7dfea6b1087542dd461226569101de
+DIST capstone-6.0.0_alpha1.tar.gz 9929667 BLAKE2B 2a32026b943759e2c9d5dfa52c176112f6fcbfda0d1b64349bc2f4a587e41d929cd1a23e17ac94d8eb92e277878b1e1da671fd10dea2e7b43fc2361518f60504 SHA512 f95da568693b8bfe350c366ecd90b406754c3cfb9ac2ece772b67edf01aded5cb88d1b1190c6ec39c99506e50d89d93e33af8cb2892c03f6555d4eb39fc2d531
diff --git a/dev-libs/capstone/capstone-6.0.0_alpha1.ebuild b/dev-libs/capstone/capstone-6.0.0_alpha1.ebuild
new file mode 100644
index 000000000000..8d6006b4688e
--- /dev/null
+++ b/dev-libs/capstone/capstone-6.0.0_alpha1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_EXT=1
+DISTUTILS_OPTIONAL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit cmake distutils-r1 toolchain-funcs
+
+DESCRIPTION="disassembly/disassembler framework + bindings"
+HOMEPAGE="https://www.capstone-engine.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/capstone-engine/capstone.git"
+ EGIT_REPO_BRANCH="next"
+else
+ MY_PV="${PV}"
+ MY_PV="${MY_PV/_alpha/-Alpha}"
+ MY_PV="${MY_PV/_beta/-Beta}"
+ MY_PV="${MY_PV/_rc/-rc}"
+ SRC_URI="https://github.com/capstone-engine/capstone/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+ if [[ ${PV} != *_alpha* && ${PV} != *_beta* && ${PV} != *_rc* ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+ fi
+fi
+
+LICENSE="BSD"
+SLOT="0/6" # libcapstone.so.6
+
+IUSE="python static-libs test"
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ python? ( dev-python/setuptools[${PYTHON_USEDEP}] )
+"
+BDEPEND="${DISTUTILS_DEPS}"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ # Currently "-Werror" is only added in the `next`-development branch, but
+ # not merged into 5.* releases. Eventually this patch may be needed in the
+ # version 5 release line. See bug #911481.
+ "${FILESDIR}/${PN}-werror.patch"
+)
+
+if [[ ${PV} == *_rc* ]]; then
+ # Upstream doesn't flag release candidates (bug 858350)
+ QA_PKGCONFIG_VERSION=""
+fi
+
+wrap_python() {
+ local phase=$1
+ shift
+
+ if use python; then
+ pushd "${S}/bindings/python" >/dev/null || die
+ distutils-r1_${phase} "$@"
+ popd >/dev/null || die
+ fi
+}
+
+src_prepare() {
+ tc-export RANLIB
+ cmake_src_prepare
+
+ wrap_python ${FUNCNAME}
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=true
+ -DCAPSTONE_BUILD_STATIC_RUNTIME=false
+ )
+ cmake_src_configure
+
+ wrap_python ${FUNCNAME}
+}
+
+src_compile() {
+ cmake_src_compile
+
+ wrap_python ${FUNCNAME}
+}
+
+src_test() {
+ cmake_src_test
+
+ wrap_python ${FUNCNAME}
+}
+
+src_install() {
+ cmake_src_install
+
+ wrap_python ${FUNCNAME}
+}
+
+python_test() {
+ ./tests/test_all.py || die
+ ./tests/test_iter.py || die
+}
diff --git a/dev-libs/capstone/files/capstone-9999-werror.patch b/dev-libs/capstone/files/capstone-werror.patch
index d5f09ca7d656..d5f09ca7d656 100644
--- a/dev-libs/capstone/files/capstone-9999-werror.patch
+++ b/dev-libs/capstone/files/capstone-werror.patch