summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-01-01 05:03:38 -0500
committerAnthony G. Basile <blueness@gentoo.org>2016-01-01 05:05:01 -0500
commit764e6e8f0d575abba7fcd83a2e7f36d3aa660a93 (patch)
tree3ea9d33ad44dec2362d6adaa3dc118ea7d6bf558 /dev-libs
parentdev-db/mongodb: [QA] Make SCons respect PATH, #570436 (diff)
downloadgentoo-764e6e8f0d575abba7fcd83a2e7f36d3aa660a93.tar.gz
gentoo-764e6e8f0d575abba7fcd83a2e7f36d3aa660a93.tar.bz2
gentoo-764e6e8f0d575abba7fcd83a2e7f36d3aa660a93.zip
dev-libs/xapian: version bump to 1.3.4
Package-Manager: portage-2.2.24
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/xapian/Manifest1
-rw-r--r--dev-libs/xapian/xapian-1.2.22.ebuild10
-rw-r--r--dev-libs/xapian/xapian-1.3.3-r2.ebuild12
-rw-r--r--dev-libs/xapian/xapian-1.3.4.ebuild69
4 files changed, 81 insertions, 11 deletions
diff --git a/dev-libs/xapian/Manifest b/dev-libs/xapian/Manifest
index 5fd94c8033fd..1662f287e509 100644
--- a/dev-libs/xapian/Manifest
+++ b/dev-libs/xapian/Manifest
@@ -2,3 +2,4 @@ DIST xapian-core-1.2.19.tar.xz 3175384 SHA256 4a78260388ff1b042f0ab5d18afdd524a5
DIST xapian-core-1.2.21.tar.xz 3202560 SHA256 63f48758fbd13fa8456dd4cf9bf3ec35a096e4290f14a51ac7df23f78c162d3f SHA512 a821043ea1686a09178bb91b14ed6a8cf00c50dfb0f066e420a40395edd3be085d7f89abb8f6a1151c847272c13601274e645055ede3548b07d5e912f0a70f81 WHIRLPOOL 9de8b2b70252b87da16a2502a831b46857f48cca8623a6ac411291bb6607bd61968ddd64a77c8685f300818abcbf91149a3f43af849a7843f67a5ebcc5130963
DIST xapian-core-1.2.22.tar.xz 3204096 SHA256 269b87ca3faf79d444e8bb82ed58a96f1955008d7702f9966dec68608588527f SHA512 cb6bd565eb307f9bc8f801fc9cda0cc6ad5d7cb8bf0af2ab6e42d48ca4ea4169f08621db810ab87d15957d0f873bcb0336e16b12fdb6026375d9c0192781e0d6 WHIRLPOOL 580c16889a6c3e99a00f8bb791f878a08ff3522c3dffb18ace18d54575247332f0fff8866f46475513dde7544205fe08971cbd284ec3714ce0d6b9b445e8746e
DIST xapian-core-1.3.3.tar.xz 2543260 SHA256 2d273ca0df6af208c4b6904542a9dffed8a9520376522d650e1a2885b476a280 SHA512 8b0d0fce532748efc1c2705e3f6f45ff83ec97be7c1f5b54846a9ff94b9d416b67491262a157afdc40497c52e1c4aa94bd11a78b4494db4a1fb45ba6d18f7099 WHIRLPOOL bf9c2f1606ba72469f2306cc6edfff63834c58831ee75063e39445392460b85478c9c44ef7d2ec1fdfd63bad113544f8c1ba3eb01ee178abf63da3a7ae2d5b3b
+DIST xapian-core-1.3.4.tar.xz 2570240 SHA256 0a49da54a1eecb43de657f6341fde386f4c6e6bd1d2d64f77212adfc44bf67d4 SHA512 b616eb3532aaf7a00f58e6f21fa7309e434f9e598322793d2e81fe90da2a9d343518c9900bd30686594efeb24d370099f0df8f3a30afadb613ba19638f700617 WHIRLPOOL 167df88df4d12548e69e97e1163487f8a0eef93daedbac2c4a0bd4e4515dc2932c2bd044b2ec4905d251fdc69b460cb4ada67b511c2bfd8495eff8c5697b5271
diff --git a/dev-libs/xapian/xapian-1.2.22.ebuild b/dev-libs/xapian/xapian-1.2.22.ebuild
index 54e12ecec157..7893178b513a 100644
--- a/dev-libs/xapian/xapian-1.2.22.ebuild
+++ b/dev-libs/xapian/xapian-1.2.22.ebuild
@@ -25,20 +25,20 @@ S="${WORKDIR}/${MY_P}"
src_configure() {
local myconf=""
- ewarn
+ einfo
if use cpu_flags_x86_sse2; then
- ewarn "Using sse2"
+ einfo "Using sse2"
myconf="${myconf} --enable-sse=sse2"
else
if use cpu_flags_x86_sse; then
- ewarn "Using sse"
+ einfo "Using sse"
myconf="${myconf} --enable-sse=sse"
else
- ewarn "Disabling sse and sse2"
+ einfo "Disabling sse and sse2"
myconf="${myconf} --disable-sse"
fi
fi
- ewarn
+ einfo
myconf="${myconf} $(use_enable static-libs static)"
diff --git a/dev-libs/xapian/xapian-1.3.3-r2.ebuild b/dev-libs/xapian/xapian-1.3.3-r2.ebuild
index 58616c523fb5..6042a7453f7c 100644
--- a/dev-libs/xapian/xapian-1.3.3-r2.ebuild
+++ b/dev-libs/xapian/xapian-1.3.3-r2.ebuild
@@ -13,7 +13,7 @@ HOMEPAGE="http://www.xapian.org/"
SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz"
LICENSE="GPL-2"
-SLOT="0/1.3.4" # ABI version of libxapian-1.3.so, prefixed with 1.3.
+SLOT="0/1.3.5" # ABI version of libxapian-1.3.so, prefixed with 1.3.
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="doc static-libs -cpu_flags_x86_sse +cpu_flags_x86_sse2 +brass +chert +inmemory"
@@ -27,20 +27,20 @@ S="${WORKDIR}/${MY_P}"
src_configure() {
local myconf=""
- ewarn
+ einfo
if use cpu_flags_x86_sse2; then
- ewarn "Using sse2"
+ einfo "Using sse2"
myconf="${myconf} --enable-sse=sse2"
else
if use cpu_flags_x86_sse; then
- ewarn "Using sse"
+ einfo "Using sse"
myconf="${myconf} --enable-sse=sse"
else
- ewarn "Disabling sse and sse2"
+ einfo "Disabling sse and sse2"
myconf="${myconf} --disable-sse"
fi
fi
- ewarn
+ einfo
myconf="${myconf} $(use_enable static-libs static)"
diff --git a/dev-libs/xapian/xapian-1.3.4.ebuild b/dev-libs/xapian/xapian-1.3.4.ebuild
new file mode 100644
index 000000000000..58616c523fb5
--- /dev/null
+++ b/dev-libs/xapian/xapian-1.3.4.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+MY_P="${PN}-core-${PV}"
+
+DESCRIPTION="Xapian Probabilistic Information Retrieval library"
+HOMEPAGE="http://www.xapian.org/"
+SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/1.3.4" # ABI version of libxapian-1.3.so, prefixed with 1.3.
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc static-libs -cpu_flags_x86_sse +cpu_flags_x86_sse2 +brass +chert +inmemory"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="inmemory? ( chert )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local myconf=""
+
+ ewarn
+ if use cpu_flags_x86_sse2; then
+ ewarn "Using sse2"
+ myconf="${myconf} --enable-sse=sse2"
+ else
+ if use cpu_flags_x86_sse; then
+ ewarn "Using sse"
+ myconf="${myconf} --enable-sse=sse"
+ else
+ ewarn "Disabling sse and sse2"
+ myconf="${myconf} --disable-sse"
+ fi
+ fi
+ ewarn
+
+ myconf="${myconf} $(use_enable static-libs static)"
+
+ use brass || myconf="${myconf} --disable-backend-brass"
+ use chert || myconf="${myconf} --disable-backend-chert"
+ use inmemory || myconf="${myconf} --disable-backend-inmemory"
+
+ myconf="${myconf} --enable-backend-remote --program-suffix="
+
+ econf $myconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ mv "${D}usr/share/doc/xapian-core" "${D}usr/share/doc/${PF}" || die
+ use doc || rm -rf "${D}usr/share/doc/${PF}"
+
+ dodoc AUTHORS HACKING PLATFORMS README NEWS
+
+ prune_libtool_files --all
+}
+
+src_test() {
+ emake check VALGRIND=
+}