summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-02 05:51:42 +0100
committerSam James <sam@gentoo.org>2021-04-03 16:54:36 +0100
commitc0171f1e1dc61d4b281177e8b7351b78f575577d (patch)
treeda1cb6afbaf7f4dcb7ed1bdda503eeecbeb41939 /dev-libs/uulib
parentdev-libs/squareball: EAPI 7, eutils--, ltprune-- (diff)
downloadgentoo-c0171f1e1dc61d4b281177e8b7351b78f575577d.tar.gz
gentoo-c0171f1e1dc61d4b281177e8b7351b78f575577d.tar.bz2
gentoo-c0171f1e1dc61d4b281177e8b7351b78f575577d.zip
dev-libs/uulib: EAPI 7, fix libtool invocation, eutils--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/uulib')
-rw-r--r--dev-libs/uulib/files/uulib-0.5.20-shared.patch6
-rw-r--r--dev-libs/uulib/uulib-0.5.20-r1.ebuild31
2 files changed, 28 insertions, 9 deletions
diff --git a/dev-libs/uulib/files/uulib-0.5.20-shared.patch b/dev-libs/uulib/files/uulib-0.5.20-shared.patch
index 3a7f6582ef4e..fade48fb5932 100644
--- a/dev-libs/uulib/files/uulib-0.5.20-shared.patch
+++ b/dev-libs/uulib/files/uulib-0.5.20-shared.patch
@@ -2,10 +2,8 @@ Source: PDL Linux
https://raw.githubusercontent.com/pld-linux/uudeview/master/uudeview-shared.patch
https://github.com/pld-linux/uudeview
-
-diff -ruN uudeview-0.5.20.orig/uulib/Makefile.in uudeview-0.5.20/uulib/Makefile.in
---- uudeview-0.5.20.orig/uulib/Makefile.in 2002-03-11 10:15:46.000000000 +0100
-+++ uudeview-0.5.20/uulib/Makefile.in 2014-10-11 20:20:04.280175737 +0200
+--- a/Makefile.in
++++ b/Makefile.in
@@ -40,9 +40,13 @@
VDEF = -DVERSION=\"$(VERSION)\" -DPATCH=\"$(PATCH)\"
#
diff --git a/dev-libs/uulib/uulib-0.5.20-r1.ebuild b/dev-libs/uulib/uulib-0.5.20-r1.ebuild
index 96c0207408d5..18563655e646 100644
--- a/dev-libs/uulib/uulib-0.5.20-r1.ebuild
+++ b/dev-libs/uulib/uulib-0.5.20-r1.ebuild
@@ -1,25 +1,46 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils toolchain-funcs
+inherit autotools toolchain-funcs
MY_P=uudeview-${PV}
DESCRIPTION="Library that supports Base64 (MIME), uuencode, xxencode and binhex coding"
HOMEPAGE="http://www.fpx.de/fp/Software/UUDeview/"
SRC_URI="http://www.fpx.de/fp/Software/UUDeview/download/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}/${PN}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-S=${WORKDIR}/${MY_P}/${PN}
+BDEPEND="sys-devel/libtool"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-shared.patch
+)
src_prepare() {
- epatch "${FILESDIR}/${P}-shared.patch"
+ default
+
sed -i 's:\<ar\>:$(AR):' Makefile.in || die
+ # Fix Darwin and other platforms with a non-GNU default libtool
+ sed -i 's/libtool/$(LIBTOOL)/' Makefile.in || die
+}
+
+src_configure() {
tc-export AR CC RANLIB
+ econf
+}
+
+src_compile() {
+ if use prefix ; then
+ LIBTOOL=glibtool
+ else
+ LIBTOOL=libtool
+ fi
+
+ LIBTOOL="${LIBTOOL}" emake
}