summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/mini-xml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/mini-xml')
-rw-r--r--dev-libs/mini-xml/Manifest2
-rw-r--r--dev-libs/mini-xml/metadata.xml9
-rw-r--r--dev-libs/mini-xml/mini-xml-2.7-r1.ebuild61
-rw-r--r--dev-libs/mini-xml/mini-xml-2.8.ebuild61
4 files changed, 133 insertions, 0 deletions
diff --git a/dev-libs/mini-xml/Manifest b/dev-libs/mini-xml/Manifest
new file mode 100644
index 000000000000..c9dd5a196127
--- /dev/null
+++ b/dev-libs/mini-xml/Manifest
@@ -0,0 +1,2 @@
+DIST mxml-2.7.tar.gz 262027 SHA256 a77200ee4c1e1cf2eb531595ec17ce31805760699d260915496c39d3388eb803 SHA512 9fac34975c35d0ff9686a20a882824040b0b96b38ab9f1f5b1ef24a323668974860d4d977bb07c90a3e2b3410a2d8358eec1682b2c7ff2cda7f36f630ff97007 WHIRLPOOL 1c899377e69f2763e9502d60e957aa0318710f45b57ebc2099090e8439d27f7024bdeaa59042edf202aa1579f81d3e6296f7718dd7bc34faf346967ad6b05d64
+DIST mxml-2.8.tar.gz 264044 SHA256 0c9369f91a718d82e32cb007c0bd41b6642822c9a0ffe1d10eccbdea9a3011d5 SHA512 f6ecb9edfe9917137b47b41be941b22c1054b38e7f2e16977a0e9dfa554f2e62886fc65ac404e4445f10fba7c6dbb30a235525cccba75c9daf3da4ba251cf3bd WHIRLPOOL ab3c058f63820d19dfe6a359552a61ad5c18a73aa9f8fb728a2524e8ddde5dcc9843cd8aab2c07ba1649e3ca92a705856c11d4dabfb6f345360cf086f924e2d1
diff --git a/dev-libs/mini-xml/metadata.xml b/dev-libs/mini-xml/metadata.xml
new file mode 100644
index 000000000000..5eb541d497f3
--- /dev/null
+++ b/dev-libs/mini-xml/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>ruepel@gmx.li</email>
+ <name>Rüpel</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-libs/mini-xml/mini-xml-2.7-r1.ebuild b/dev-libs/mini-xml/mini-xml-2.7-r1.ebuild
new file mode 100644
index 000000000000..410e40fcb900
--- /dev/null
+++ b/dev-libs/mini-xml/mini-xml-2.7-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools multilib
+
+MY_P="${P/mini-xml/mxml}"
+
+DESCRIPTION="Small XML parsing library to read XML and XML-like data files"
+HOMEPAGE="http://www.minixml.org/"
+SRC_URI="http://www.msweet.org/files/project3/${MY_P}.tar.gz"
+
+LICENSE="Mini-XML"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="threads static-libs"
+
+DEPEND="virtual/pkgconfig"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -i -e "s:755 -s:755:" Makefile.in || die "sed failed"
+ sed -i "/^TARGETS/s: testmxml::" Makefile.in || die "sed failed"
+ sed -i -e 's:$(DSO) $(DSOFLAGS) -o libmxml.so.1.5 $(LIBOBJS):$(DSO) $(DSOFLAGS) $(LDFLAGS) -o libmxml.so.1.5 $(LIBOBJS):' \
+ Makefile.in || die "sed failed"
+ sed -i -e 's:OPTIM="-Os -g":OPTIM="":' configure.in || die "sed failed"
+ rm configure
+# eautoreconf
+ eautoconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --libdir="/usr/$(get_libdir)" \
+ --with-docdir="/usr/share/doc/${PF}/html" \
+ $(use_enable threads)
+}
+
+src_compile() {
+ emake libmxml.so.1.5 mxmldoc doc/mxml.man || die "make failed"
+}
+
+src_install() {
+ emake DSTROOT="${D}" install || die "install failed"
+
+ if ! use static-libs; then
+ rm -vf "${ED}"/usr/$(get_libdir)/libmxml.a || die
+ fi
+
+ dodoc ANNOUNCEMENT CHANGES README
+ rm "${D}/usr/share/doc/${PF}/html/"{CHANGES,COPYING,README}
+}
+
+src_test() {
+ emake testmxml || die "make testmxml failed"
+}
diff --git a/dev-libs/mini-xml/mini-xml-2.8.ebuild b/dev-libs/mini-xml/mini-xml-2.8.ebuild
new file mode 100644
index 000000000000..8be99c5b82f7
--- /dev/null
+++ b/dev-libs/mini-xml/mini-xml-2.8.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools multilib
+
+MY_P="${P/mini-xml/mxml}"
+
+DESCRIPTION="Small XML parsing library to read XML and XML-like data files"
+HOMEPAGE="http://www.minixml.org/"
+SRC_URI="http://www.msweet.org/files/project3/${MY_P}.tar.gz"
+
+LICENSE="Mini-XML"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86"
+IUSE="threads static-libs"
+
+DEPEND="virtual/pkgconfig"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -e "s:755 -s:755:" \
+ -e "/^TARGETS/s: testmxml::" \
+ -e 's:$(DSO) $(DSOFLAGS) -o libmxml.so.1.5 $(LIBOBJS):$(DSO) $(DSOFLAGS) $(LDFLAGS) -o libmxml.so.1.5 $(LIBOBJS):' \
+ -i Makefile.in || die "sed failed"
+ sed -i -e 's:OPTIM="-Os -g":OPTIM="":' configure.in || die "sed failed"
+ rm configure
+# eautoreconf
+ eautoconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --libdir="/usr/$(get_libdir)" \
+ --with-docdir="/usr/share/doc/${PF}/html" \
+ $(use_enable threads)
+}
+
+src_compile() {
+ emake libmxml.so.1.5 mxmldoc doc/mxml.man
+}
+
+src_install() {
+ emake DSTROOT="${D}" install
+
+ if ! use static-libs; then
+ rm "${ED}"/usr/$(get_libdir)/libmxml.a || die
+ fi
+
+ dodoc ANNOUNCEMENT CHANGES README
+ rm "${D}/usr/share/doc/${PF}/html/"{CHANGES,COPYING,README} || die
+}
+
+src_test() {
+ emake testmxml
+}