summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-02-18 17:26:18 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-02-18 17:30:49 -0800
commit73e3cff3e5c20ce30b90326849b215c31aa5cb3e (patch)
tree0aa238cade8c52020b88cd2f1c171f1aa120dd58 /dev-libs/mimetic
parenteclass/postgres{,-multi}.eclass: Note EAPI7 support (diff)
downloadgentoo-73e3cff3e5c20ce30b90326849b215c31aa5cb3e.tar.gz
gentoo-73e3cff3e5c20ce30b90326849b215c31aa5cb3e.tar.bz2
gentoo-73e3cff3e5c20ce30b90326849b215c31aa5cb3e.zip
dev-libs/mimetic: keyword on ~ppc64
add signed char patch to allow build on arches where char is unsigned ====================================== Tests Statistics -------------------------------------- Functions Checks Success 65 2740 Failed 0 0 -------------------------------------- Total 65 2740 ====================================== Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-libs/mimetic')
-rw-r--r--dev-libs/mimetic/files/signed-char.patch31
-rw-r--r--dev-libs/mimetic/mimetic-0.9.8.ebuild6
2 files changed, 35 insertions, 2 deletions
diff --git a/dev-libs/mimetic/files/signed-char.patch b/dev-libs/mimetic/files/signed-char.patch
new file mode 100644
index 000000000000..df33df9e2b72
--- /dev/null
+++ b/dev-libs/mimetic/files/signed-char.patch
@@ -0,0 +1,31 @@
+Description: fix FTBFS on architectures where char is unsigned
+ Fix error
+ base64.cxx:30:1: error: narrowing conversion of '-1' from 'int' to 'char' inside { } [-Wnarrowing]
+ by making Base64::sDecTable a signed char.
+Bug-Debian: https://bugs.debian.org/859963
+Forwarded: via email
+Author: gregor herrmann <gregoa@debian.org>
+Last-Update: 2017-04-10
+
+--- a/mimetic/codec/base64.cxx
++++ b/mimetic/codec/base64.cxx
+@@ -13,7 +13,7 @@
+ "abcdefghijklmnopqrstuvwxyz"
+ "0123456789+/=";
+
+-const char Base64::sDecTable[] = {
++const signed char Base64::sDecTable[] = {
+ -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,
+ -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,
+ -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,
+--- a/mimetic/codec/base64.h
++++ b/mimetic/codec/base64.h
+@@ -20,7 +20,7 @@
+ enum { default_maxlen = 76 };
+ enum { eq_sign = 100 };
+ static const char sEncTable[];
+- static const char sDecTable[];
++ static const signed char sDecTable[];
+ static const int sDecTableSz;
+ public:
+ class Encoder; class Decoder;
diff --git a/dev-libs/mimetic/mimetic-0.9.8.ebuild b/dev-libs/mimetic/mimetic-0.9.8.ebuild
index ffa4669138a1..3f54ec09712e 100644
--- a/dev-libs/mimetic/mimetic-0.9.8.ebuild
+++ b/dev-libs/mimetic/mimetic-0.9.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -11,11 +11,13 @@ SRC_URI="http://www.codesink.org/download/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="amd64 ~ppc64 x86"
IUSE="doc examples"
DEPEND="doc? ( app-doc/doxygen )"
+PATCHES=( "${FILESDIR}/signed-char.patch" )
+
src_prepare() {
default