summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-25 05:28:47 +0100
committerSam James <sam@gentoo.org>2023-05-25 05:31:57 +0100
commitfb0eb4f9bf93b8524a8140265f03b1526597861f (patch)
tree7d385a2e5bf7e004ed50299dc175436f37963f5f /dev-libs/libxml2
parentdev-python/cffi: add another py3.12 issue to comment (diff)
downloadgentoo-fb0eb4f9bf93b8524a8140265f03b1526597861f.tar.gz
gentoo-fb0eb4f9bf93b8524a8140265f03b1526597861f.tar.bz2
gentoo-fb0eb4f9bf93b8524a8140265f03b1526597861f.zip
dev-libs/libxml2: enable py3.12, sync live
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libxml2')
-rw-r--r--dev-libs/libxml2/libxml2-2.11.4.ebuild2
-rw-r--r--dev-libs/libxml2/libxml2-9999.ebuild6
2 files changed, 6 insertions, 2 deletions
diff --git a/dev-libs/libxml2/libxml2-2.11.4.ebuild b/dev-libs/libxml2/libxml2-2.11.4.ebuild
index e421de936733..45757ffa2a9d 100644
--- a/dev-libs/libxml2/libxml2-2.11.4.ebuild
+++ b/dev-libs/libxml2/libxml2-2.11.4.ebuild
@@ -5,7 +5,7 @@ EAPI=8
# Note: Please bump in sync with dev-libs/libxslt
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="xml(+)"
inherit flag-o-matic python-r1 multilib-minimal
diff --git a/dev-libs/libxml2/libxml2-9999.ebuild b/dev-libs/libxml2/libxml2-9999.ebuild
index b7e202fefbb5..45757ffa2a9d 100644
--- a/dev-libs/libxml2/libxml2-9999.ebuild
+++ b/dev-libs/libxml2/libxml2-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=8
# Note: Please bump in sync with dev-libs/libxslt
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="xml(+)"
inherit flag-o-matic python-r1 multilib-minimal
@@ -101,6 +101,10 @@ multilib_src_configure() {
# Filter seemingly problematic CFLAGS (bug #26320)
filter-flags -fprefetch-loop-arrays -funroll-loops
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ append-libs iconv
+ fi
+
# Notes:
# The meaning of the 'debug' USE flag does not apply to the --with-debug
# switch (enabling the libxml2 debug module). See bug #100898.