summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Byrne <salah.coronya@gmail.com>2021-06-01 14:24:31 -0500
committerJoonas Niilola <juippis@gentoo.org>2021-06-22 11:29:44 +0300
commita88129cec9b0fba20f944fd2510ae52bd3588f83 (patch)
treee288e03629b59c4c2659592529c9593ede0231fa /dev-libs/libtpms
parentdev-python/isort: Add missing test-dep on natsort (diff)
downloadgentoo-a88129cec9b0fba20f944fd2510ae52bd3588f83.tar.gz
gentoo-a88129cec9b0fba20f944fd2510ae52bd3588f83.tar.bz2
gentoo-a88129cec9b0fba20f944fd2510ae52bd3588f83.zip
dev-libs/libtpms: Bump to 0.8.3
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Christopher Byrne <salah.coronya@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/libtpms')
-rw-r--r--dev-libs/libtpms/Manifest1
-rw-r--r--dev-libs/libtpms/libtpms-0.8.3.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/libtpms/Manifest b/dev-libs/libtpms/Manifest
index 93f2642fb368..fa9ee38e060d 100644
--- a/dev-libs/libtpms/Manifest
+++ b/dev-libs/libtpms/Manifest
@@ -1 +1,2 @@
DIST libtpms-0.8.2.tar.gz 1253915 BLAKE2B 48281512f2611376f0f3a67a2646fdc406c2d28bfd560a07b23c122a1b4d68c2840c5cd23f41beae4a13eab419e722aed821cecd919ae6219da325724d55e3b3 SHA512 635f1b30265f1752602caefa1fa87f0032e4d38f1b7113137b7e25a85da10e34f89f9d928b960660e9451306807f111ed96c2a11cbb2de4fb4beb7e638f83727
+DIST libtpms-0.8.3.tar.gz 1254474 BLAKE2B c71f52d6475d4328e93a35f88557de3400308984ec086f7e6b3c32ebc266e078b3a9864396546ba11fc310c1572efa1521bdac89075c5eba18cb35eef883e706 SHA512 07cf78c2a5b03f3c9179b041db57d5ec049dc0085c09e4fd5c9b54a247cf81a3b9982f0fb1cd571cd6b21b3d9824b061f8f38508fc25b6a23a6a6b06dea7115b
diff --git a/dev-libs/libtpms/libtpms-0.8.3.ebuild b/dev-libs/libtpms/libtpms-0.8.3.ebuild
new file mode 100644
index 000000000000..d8fb23739da2
--- /dev/null
+++ b/dev-libs/libtpms/libtpms-0.8.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Library providing software emultion of a TPM"
+HOMEPAGE="https://github.com/stefanberger/libtpms"
+SRC_URI="https://github.com/stefanberger/libtpms/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-libs/openssl:0="
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.8.0-Remove-WError.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --with-openssl \
+ --with-tpm2
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "Versions of libtpms prior to 0.8.0 generate weaker than expected TPM 2.0 RSA"
+ elog "keys due to a flawed key creation algorithm. Because fixing this would render"
+ elog "existing sealed data inaccessible, to use the corrected algorithm, the old"
+ elog "TPM state file must be deleted and a new TPM state file created. Data still"
+ elog "sealed using the old state file will be permanently inaccessible. For the"
+ elog "details see https://github.com/stefanberger/libtpms/issues/183"
+}