summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-14 10:19:51 +0100
committerSam James <sam@gentoo.org>2024-06-14 10:32:34 +0100
commit34c96163c6e136c139a065d22346b6ebdb7bac52 (patch)
treee0a1dba500a93bf3f9c0160992ddfabe53c95c0e /dev-libs/libqt5pas
parentsys-auth/libfprint: Stabilize 1.94.7 arm, #934239 (diff)
downloadgentoo-34c96163c6e136c139a065d22346b6ebdb7bac52.tar.gz
gentoo-34c96163c6e136c139a065d22346b6ebdb7bac52.tar.bz2
gentoo-34c96163c6e136c139a065d22346b6ebdb7bac52.zip
dev-libs/libqt5pas: add 1.2.15
Bug: https://bugs.gentoo.org/934158 Bug: https://bugs.gentoo.org/934235 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libqt5pas')
-rw-r--r--dev-libs/libqt5pas/Manifest1
-rw-r--r--dev-libs/libqt5pas/libqt5pas-1.2.15.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/libqt5pas/Manifest b/dev-libs/libqt5pas/Manifest
index ee7b671dbf1f..d506640c7770 100644
--- a/dev-libs/libqt5pas/Manifest
+++ b/dev-libs/libqt5pas/Manifest
@@ -1 +1,2 @@
+DIST libqt5pas-1.2.15.tar.gz 87513233 BLAKE2B 26e8492194541453230832591445b97827e65b61531078cb4bd1c9f549bcd0aa531fef036f701de885e96f9e56476b0dd1c9465e2388ea43080ba418acbd097e SHA512 85cb3548fab017f2fd97f5fb141d59a0d0ec1412a161f98fea726ad5d6ed32ee2eb6ef6573e058d4df7dfcc067256e842acf994b73c9a50ebfb064657db33881
DIST libqt5pas-1.2.9.tar.gz 77272959 BLAKE2B 2d7b2872a7399eb1a3a7d9fb20fed209900603ae433db75ac2c4244edf5e5981314ed3d8e39143ff30764e7ccbf1286edace9c38505df1cd28b44250bdd07224 SHA512 1a2fbc8451f1954df1d0071c586662ebc3cd0e9a7db5d910e0af86a3095252a5796d4c7abcf3861ad723af26974ac416c5bf919cd77ad5f406295ad7cdf47eb1
diff --git a/dev-libs/libqt5pas/libqt5pas-1.2.15.ebuild b/dev-libs/libqt5pas/libqt5pas-1.2.15.ebuild
new file mode 100644
index 000000000000..7c1e535c3618
--- /dev/null
+++ b/dev-libs/libqt5pas/libqt5pas-1.2.15.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Get PV from lcl/interfaces/qt5/cbindings/Qt5Pas.pro
+inherit qmake-utils
+
+# We want to keep the version here in correspondence with dev-lang/lazarus
+# so dev-lang/lazarus can use the bindings.
+MY_P="lazarus-3.0-0"
+
+DESCRIPTION="Free Pascal Qt5 bindings library updated by lazarus IDE"
+HOMEPAGE="https://gitlab.com/freepascal.org/lazarus/lazarus"
+SRC_URI="https://downloads.sourceforge.net/lazarus/${MY_P}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/lazarus/lcl/interfaces/qt5/cbindings"
+
+LICENSE="LGPL-3"
+SLOT="0/3.0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ eqmake5 "QT += x11extras" Qt5Pas.pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}