summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-12 23:24:46 +0000
committerSam James <sam@gentoo.org>2021-01-12 23:34:12 +0000
commitbc719dc6a1f6912dcf71efdf2feef7352510b456 (patch)
treebf24ad8915808e797385018e39e185fb25aa3de1 /dev-libs/libdnet
parentdev-libs/libnl: add Python 3.9 (diff)
downloadgentoo-bc719dc6a1f6912dcf71efdf2feef7352510b456.tar.gz
gentoo-bc719dc6a1f6912dcf71efdf2feef7352510b456.tar.bz2
gentoo-bc719dc6a1f6912dcf71efdf2feef7352510b456.zip
dev-libs/libdnet: add Python 3.9
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libdnet')
-rw-r--r--dev-libs/libdnet/libdnet-1.14-r1.ebuild31
-rw-r--r--dev-libs/libdnet/libdnet-1.14-r2.ebuild2
2 files changed, 16 insertions, 17 deletions
diff --git a/dev-libs/libdnet/libdnet-1.14-r1.ebuild b/dev-libs/libdnet/libdnet-1.14-r1.ebuild
index 3d34dd007371..58293f3bd059 100644
--- a/dev-libs/libdnet/libdnet-1.14-r1.ebuild
+++ b/dev-libs/libdnet/libdnet-1.14-r1.ebuild
@@ -1,31 +1,30 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
AT_M4DIR="config"
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
DISTUTILS_OPTIONAL=1
inherit autotools distutils-r1
DESCRIPTION="simplified, portable interface to several low-level networking routines"
HOMEPAGE="https://github.com/ofalk/libdnet"
SRC_URI="https://github.com/ofalk/${PN}/archive/${P}.tar.gz"
-LICENSE="LGPL-2"
+S="${WORKDIR}/${PN}-${P}"
+LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86"
IUSE="python static-libs test"
-
-DEPEND="
- python? ( ${PYTHON_DEPS} )
-"
-RDEPEND="
- ${DEPEND}
-"
-RESTRICT="test"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="test"
+
+DEPEND="python? ( ${PYTHON_DEPS} )"
+RDEPEND="${DEPEND}"
+
DOCS=( README.md THANKS TODO )
-S=${WORKDIR}/${PN}-${P}
+
PATCHES=(
"${FILESDIR}"/${PN}-1.14-ndisc.patch
"${FILESDIR}"/${PN}-1.14-strlcpy.patch
@@ -48,7 +47,7 @@ src_prepare() {
eautoreconf
if use python; then
- cd python
+ cd python || die
distutils-r1_src_prepare
fi
}
@@ -62,7 +61,7 @@ src_configure() {
src_compile() {
default
if use python; then
- cd python
+ cd python || die
distutils-r1_src_compile
fi
}
@@ -70,9 +69,9 @@ src_compile() {
src_install() {
default
if use python; then
- cd python
+ cd python || die
unset DOCS
distutils-r1_src_install
fi
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -delete || die
}
diff --git a/dev-libs/libdnet/libdnet-1.14-r2.ebuild b/dev-libs/libdnet/libdnet-1.14-r2.ebuild
index 2938cfe88b82..f6b3a828e42c 100644
--- a/dev-libs/libdnet/libdnet-1.14-r2.ebuild
+++ b/dev-libs/libdnet/libdnet-1.14-r2.ebuild
@@ -4,7 +4,7 @@
EAPI=7
AT_M4DIR="config"
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
DISTUTILS_OPTIONAL=1
inherit autotools distutils-r1