summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-09 09:58:50 +0200
committerDavid Seifert <soap@gentoo.org>2022-09-09 09:58:50 +0200
commitc362342fc9239f8d6ff8ae536f905de74f1fbe2d (patch)
treed947d9930104c3e8c98b7808b321d31c6f21d099 /dev-libs/jthread
parentdev-libs/iniparser: drop multilib, EAPI 8 (diff)
downloadgentoo-c362342fc9239f8d6ff8ae536f905de74f1fbe2d.tar.gz
gentoo-c362342fc9239f8d6ff8ae536f905de74f1fbe2d.tar.bz2
gentoo-c362342fc9239f8d6ff8ae536f905de74f1fbe2d.zip
dev-libs/jthread: drop multilib, static-libs, EAPI 8
No reverse dependencies (hence no multilib reverse dependencies). Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/jthread')
-rw-r--r--dev-libs/jthread/jthread-1.3.3-r1.ebuild (renamed from dev-libs/jthread/jthread-1.3.3.ebuild)13
1 files changed, 5 insertions, 8 deletions
diff --git a/dev-libs/jthread/jthread-1.3.3.ebuild b/dev-libs/jthread/jthread-1.3.3-r1.ebuild
index 07be46306898..d3d9dfc88a32 100644
--- a/dev-libs/jthread/jthread-1.3.3.ebuild
+++ b/dev-libs/jthread/jthread-1.3.3-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit cmake-multilib
+inherit cmake
DESCRIPTION="JThread provides some classes to make use of threads easy on different platforms"
HOMEPAGE="https://research.edm.uhasselt.be/jori/page/CS/Jthread.html"
@@ -13,14 +13,11 @@ LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="amd64 x86"
-IUSE="static-libs"
-
DOCS=( ChangeLog README.md doc/manual.tex )
src_prepare() {
- # do not build static library, if it is not requested
- if ! use static-libs; then
- sed -i -e '/jthread-static/d' src/CMakeLists.txt || die 'sed on src/CMakeLists.txt failed'
- fi
+ # Do not build static library
+ sed -i -e '/jthread-static/d' src/CMakeLists.txt || die 'sed on src/CMakeLists.txt failed'
+
cmake_src_prepare
}