summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-12-29 12:09:39 +0100
committerPacho Ramos <pacho@gentoo.org>2015-12-29 13:07:34 +0100
commit15095ca164b9dcc5a77b9878f6b97f183ffeb98d (patch)
tree0381d799c7bc76fbbd39f835ab1c35298ddef67d /dev-libs/fampp2
parentdev-perl/CDDB_get: Remove old (diff)
downloadgentoo-15095ca164b9dcc5a77b9878f6b97f183ffeb98d.tar.gz
gentoo-15095ca164b9dcc5a77b9878f6b97f183ffeb98d.tar.bz2
gentoo-15095ca164b9dcc5a77b9878f6b97f183ffeb98d.zip
dev-libs/fampp2: Fix building with latest glibmm/libsigc++ (#569700)
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-libs/fampp2')
-rw-r--r--dev-libs/fampp2/fampp2-7.0.1-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/fampp2/fampp2-7.0.1-r1.ebuild b/dev-libs/fampp2/fampp2-7.0.1-r1.ebuild
new file mode 100644
index 000000000000..665bb038be7d
--- /dev/null
+++ b/dev-libs/fampp2/fampp2-7.0.1-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="C++ wrapper for fam"
+HOMEPAGE="https://sourceforge.net/projects/fampp/"
+SRC_URI="mirror://sourceforge/fampp/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples stlport"
+
+RDEPEND="virtual/fam
+ stlport? ( dev-libs/STLport )
+ >=dev-libs/ferrisloki-2.0.3[stlport?]
+ >=dev-libs/libsigc++-2.6:2
+ dev-libs/glib:2
+ x11-libs/gtk+:2"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # Fix compat with libsigc++-2.6
+ find -name '*.h' -exec sed -i '/sigc++\/object.h/d' {} + || die
+ find -name '*.hh' -exec sed -i '/sigc++\/object.h/d' {} + || die
+ find -name '*.cpp' -exec sed -i '/sigc++\/object.h/d' {} + || die
+ find -name '*.cpp' -exec sed -i '/sigc++\/object_slot.h/d' {} + || die
+ append-cxxflags -std=c++11
+
+ sed -ri \
+ -e '/^C(XX)?FLAGS/s:-O0 -g::' \
+ -e '/^LDFLAGS/s:-Wl,-O1 -Wl,--hash-style=both::' \
+ configure || die "sed failed"
+}
+
+src_configure() {
+ # glib and gtk+ are only required for some examples
+ econf \
+ --disable-glibtest \
+ --disable-gtktest \
+ --with-stlport=/usr/include/stlport \
+ $(use_enable stlport)
+
+ if ! use examples ; then
+ sed -i -e '/^SUBDIRS/ s/examples//' Makefile.in || die "sed failed"
+ fi
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}